<!DOCTYPE html>
<html class="no-svg no-js" itemscope itemtype="http://schema.org/WebPage" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta name="Powered By" content="Kreatio Platform" />
<link rel="canonical" href="https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app" />
<link rel="syndication-source" href="/feature/4018405/scenes-bbc-groundbreaking-app" />
<link rel="original-source" href="/feature/4018405/scenes-bbc-groundbreaking-app" />
<meta http-equiv="Content-Type" content="text/html;charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="format-detection" content="telephone=no" />
<meta name="HandheldFriendly" content="True" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<meta name="google-site-verification" content="tGci50LRnB4lh1psBDfiQOWlat0mJE3zFqgK11txjNE" /> <meta name="msvalidate.01" content="EBEF18626E74108AF52FD6A90AA49369" />
<title>Behind the scenes at the BBC&#39;s groundbreaking Own It app</title>
<meta name="description" content="App designed to safeguard children online was the result of two years&#39; toil at AI&#39;s cutting edge, says product manager Jon Howard"></meta>
<meta name="keywords" content="BBC, Apple, Google, NSPCC, Chunk Digital, ai, machine learning, Artificial Intelligence"></meta>
<meta name="generator" content="Kreatio Platform" />
<meta name="DCSext.topics" content="bbc;apple;google;nspcc;chunk-digital;ai;machine-learning;artificial-intelligence" />
<meta property="article:modified_time" content="2020-07-30T14:27:16+01:00" />
<meta property="article:published_time" content="2020-07-30T09:45:40+01:00" />
<meta name="news_keywords" content="Developer,Software,Mobile ,BBC,Apple,Google,NSPCC,Chunk Digital,ai,machine learning,Artificial Intelligence" />
<meta http-equiv="Set-Cookie" content="last_page_viewed=https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app?utm_source=Adestra&amp;utm_medium=email&amp;utm_content=&amp;utm_campaign=CTG.Daily_RL.EU.A.U&amp;im_edp=141520-43eb17cb8fac5683%26campaignname%3DCTG.Daily_RL.EU.A.U&amp;utm_term=Technology%20Vendor&amp;im_company=SULIS%20SYSTEMS%20LTD&amp;utm_term=2%20to%209;path=/;expires=2020-07-30 15:27:48 +0100;domain=.computing.co.uk;" />
<meta http-equiv="Set-Cookie" content="last_visited_page=/feature/4018405/scenes-bbc-groundbreaking-app;path=/;expires=2020-07-30 15:27:55 +0100;domain=.computing.co.uk;">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="57x57">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/apple-touch-icon-76x76.png" rel="apple-touch-icon" sizes="76x76">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/icon-hires.png" rel="icon" sizes="192x192">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/icon-normal.png" rel="icon" sizes="128x128">
<link href="//assets.kreatio.net/Incisive_live/Computing/images/favicons/32x32.ico" rel="shortcut icon" type="image/png">
<meta name="msapplication-TileImage" content="https://www.computing.co.uk/images/favicons/mstile-144x144.png?100518">
<meta name="msapplication-TileColor" content="#094c81">
<meta property="og:title" content="Behind the scenes at the BBC&#39;s groundbreaking Own It app " />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app?utm_source=Adestra&amp;utm_medium=email&amp;utm_content=&amp;utm_campaign=CTG.Daily_RL.EU.A.U&amp;im_edp=141520-43eb17cb8fac5683%26campaignname%3DCTG.Daily_RL.EU.A.U&amp;utm_term=Technology%20Vendor&amp;im_company=SULIS%20SYSTEMS%20LTD&amp;utm_term=2%20to%209" />
<meta property="og:image" content="https://www.computing.co.uk/api/v1/wps/e781ffc/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-370x229.jpg" />
<meta property="og:site_name" content="" />
<meta property="og:description" content="App designed to safeguard children online was the result of two years&#39; toil at AI&#39;s cutting edge, says product manager Jon Howard" />
<meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="computing_news" /><meta name="twitter:domain" content="//www.computing.co.uk/" /><meta name="twitter:creator" content="@_JohnLeonard" /><meta name="twitter:url" content="https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app?utm_source=Adestra&amp;utm_medium=email&amp;utm_content=&amp;utm_campaign=CTG.Daily_RL.EU.A.U&amp;im_edp=141520-43eb17cb8fac5683%26campaignname%3DCTG.Daily_RL.EU.A.U&amp;utm_term=Technology%20Vendor&amp;im_company=SULIS%20SYSTEMS%20LTD&amp;utm_term=2%20to%209" /><meta name="twitter:image" content="https://www.computing.co.uk/api/v1/wps/e781ffc/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-370x229.jpg" /><meta name="twitter:description" content="App designed to safeguard children online was the result of two years&#39; toil at AI&#39;s cutting edge, says product manager Jon Howard" /><meta itemprop="description" content="App designed to safeguard children online was the result of two years&#39; toil at AI&#39;s cutting edge, says product manager Jon Howard" />
<meta itemprop="image" content="https://www.computing.co.uk/api/v1/wps/e781ffc/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-370x229.jpg" />
<link rel="preconnect" href="https://assets.computing.co.uk">
<link rel="preconnect" href="https://www.incisive-events.com">
<link rel="preconnect" href="https://www.google-analytics.com">
<link rel="preconnect" href="https://www.googletagservices.com">
<link rel="preconnect" href="https://tpc.googlesyndication.com">
<link rel="preconnect" href="https://adservice.google.com">
<link rel="preconnect" href="https://adservice.google.co.uk">
<link rel="preconnect" href="https://js-agent.newrelic.com">
<link rel="preconnect" href="https://bam.nr-data.net">
<link rel="preconnect" href="https://d1l6p2sc9645hc.cloudfront.net">
<link rel="preconnect" href="https://data.gosquared.com">
<link rel="preconnect" href="https://data2.gosquared.com">
<link rel="preconnect" href="https://data.rci.eggplant.cloud">
<link rel="preconnect" href="https://script.crazyegg.com">
<link rel="preconnect" href="https://cdn.adsafeprotected.com">
<link rel="preconnect" href="https://static.adsafeprotected.com">
<link rel="preconnect" href="https://pixel.adsafeprotected.com">
<link rel="preconnect" href="https://fw.adsafeprotected.com">
<link rel="preconnect" href="https://s0.2mdn.net">
<link rel="preconnect" href="https://asset.pagefair.com">
<link rel="preconnect" href="https://asset.pagefair.net">
<link rel="preconnect" href="https://stats.pagefair.com">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net">
<link rel="preconnect" href="https://stats.g.doubleclick.net">
<link rel="preconnect" href="https://tag.onscroll.com">
<link rel="preload" href="https://assets.computing.co.uk/cdn/ctg/images/site-sprite.svgz" as="image" type="image/svg+xml" crossorigin="annonymous">
<link rel="preload" href="https://assets.computing.co.uk/cdn/global/images/aop-logos.svgz" as="image" type="image/svg+xml" crossorigin="annonymous">
<link rel="preload" href="https://assets.computing.co.uk/cdn/ctg/images/site-branding.svgz" as="image" type="image/svg+xml" crossorigin="annonymous">
<link href="//assets.computing.co.uk/cdn/ctg/styles/styles.css" media="all" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
<script src="http://assets.computing.co.uk/cdn/global/scripts/html5shiv.js"></script>
<link href="http://assets.computing.co.uk/respond-proxy.html" id="respond-proxy" rel="respond-proxy" />
<link href="/images/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" />
<![endif]-->
<!--[if lt IE 9]>
<script src="http://assets.computing.co.uk/cdn/global/scripts/respond.js"></script>
<script src="/javascripts/respond.proxy.js"></script>
<![endif]-->
<script type="text/javascript" language="Javascript">
		universal_variable_string = '{"content":{"article":"feature","source":"Computing","author":"john-leonard","medium":"text","published":"2020-07-30T09:45:40+01:00","tag":["bbc","apple","google","nspcc","chunk-digital","ai","machine-learning","artificial-intelligence"],"image":"/api/v1/wps/9e3eb7d/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-185x114.jpg","restriction":"default","barrier":"free"},"page":{"url":"https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app","title":"Behind the scenes at the BBC\u0026#39;s groundbreaking Own It app","description":"App designed to safeguard children online was the result of two years\u0026amp;#39; toil at AI\u0026amp;#39;s cutting edge, says product manager Jon Howard","type":"article","category":"developer","parentcategory":"software","id":"4018405","environment":"Live","site":"Computing","platform":"Desktop"}}';
	</script>
<script>
    (function(H){H.className=H.className.replace(/\bno-js\b/,'')})(document.documentElement);
    (function(H){H.className=H.className.replace(/\bno-svg\b/,'')})(document.documentElement);
    !function(){"use strict";function e(e,t,s){e.addEventListener?e.addEventListener(t,s,!1):e.attachEvent&&e.attachEvent("on"+t,s)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function s(){if(window.localStorage&&window.XMLHttpRequest)if(t(n))c(localStorage.font_css_cache);else{var e=new XMLHttpRequest;e.open("GET",n,!0),e.onreadystatechange=function(){4===e.readyState&&200===e.status&&(c(e.responseText),localStorage.font_css_cache=e.responseText,localStorage.font_css_cache_file=n)},e.send()}else{var s=document.createElement("link");s.href=n,s.rel="stylesheet",s.type="text/css",document.getElementsByTagName("head")[0].appendChild(s),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.setAttribute("type","text/css"),document.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var n="//assets.computing.co.uk/cdn/iw/styles/fonts/sourcesans_sourcesansbold.css?ver=1";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?s():e(window,"load",s)}();
</script>
<script src="//assets.computing.co.uk/cdn/ctg/scripts/jquery.2.2.4.min.js"></script>
<script src='//assets.computing.co.uk/javascript/live/computing/javascript-computing.head.min.js'></script>
<style>
  component {
    display: -webkit-box;
    border: 1px dashed #000;
    box-shadow: inset 0px 0px 10px 10px;
  }

</style>
<link rel="stylesheet" media="all" href="https://assets.kreatio.net/Incisive_live/Computing/stylesheets/article-slide.min.css" />
</head>
<body class="article article-featured Computing  ">
<div id="rdm-overlay" class="ad-slot-overlay"></div>
<div id="rdm-wallpaper" class="ad-slot-wallpaper"></div>
<div class="container">
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="menu-sidebar">
<div class="menu-sidebar-inner">
<div class="search-3 header-search-holder blur">
<form id="search_form" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" data-disable-with="" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>
</div>
<nav class="mobile-nav">
<ul class="mobile-nav-ul">
<li>
<div class="mobile-menu-title">
<a title="" href="/">Home</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/type/news">News</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/category/devops">DevOps</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/category/security">Security</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/tag/gdpr">GDPR</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/tag/artificial-intelligence">AI &amp; ML</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/tag/women-in-tech-festival">Women in Tech</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/tag/cio">CIO</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="" href="/deskflix">Deskflix</a>
</div>
</li>
</ul>
</nav>
<div class="menu-sidebar-inner">
<ul class="sidebar-list">
<li>
<a href="https://www.computing.co.uk/events" target="_blank">Events</a>
</li>
<li>
<a href="/resources" target="_blank">Whitepapers</a>
</li>
<li>
<a href="/spotlights">Spotlights</a>
</li>
<li>
<a href="/series/profile/delta-top-250-uk-it-leaders">IT Leaders 250</a>
</li>
<li>
<a href="/research">Research</a>
</li>
<li>
<a href="https://www.computingdelta.com/?utm_source=computing&amp;utm_medium=link&amp;utm_campaign=computing_commerical_nav">Delta</a>
</li>
<li>
<a href="/tag/tech-marketing-hub">Tech Marketing Hub</a>
</li>
<li>
<a href="/computing-about-us?utm_source=computing&amp;utm_medium=commercial_navigation&amp;utm_campaign=about_us">About Us</a>
</li>
<li class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</li>
</ul>
</div>
</div>
<nav class="main-top-nav">
<ul class="main-top-content main-top-menu content-width">
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-login" id="login" style="display:none;">
<a href="/userlogin">Sign in</a>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-user" id="user" style="display:none;">
<a href="/manage_account#myaccount" class="user-info"></a>

<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu">
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>

<li><a class="account-user-link" title="Account details" href="/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>

<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a title="Sign in" href="/userlogin">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a class="sign-in-user-link" title="Sign in" href="/userlogin">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-sociallinks" id="follow">
<a href="#">Follow us</a>
<ul class="header-tools-content">
<li>
<div class="nav-tools twitter-icon">
<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
</div> </li>
<li>
<div class="nav-tools linkedin">
<a href="https://www.linkedin.com/showcase/computing--/" target="_blank">LinkedIn</a>
</div> </li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</div> </li>
<li>
<div class="nav-tools facebook-icon">
<a href="https://www.facebook.com/ComputingUK" target="_blank">Facebook</a>
</div> </li>
<li>
<div class="nav-tools youtube">
<a href="https://www.youtube.com/playlist?list=PL2k5gwH-ELDedgZlV4iYGTMJKMvzSLKEA" target="_blank">YouTube</a>
</div> </li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-link main-top-register" id="register" style="display:none;">
<a href="/register" target="_blank">Register</a>
</li>
<li class="main-top-title main-top-tab-panel main-top-events" id="events">
<a href="/events" target="_blank">Events</a>
<ul class="menu-top-panel">
<li>
<div class="section group content">

<div class="col-lrg span-lrg_4_of_5 latest-events">
<header>
<div class="menu-top-panel-heading">
Upcoming events
</div>
</header>
<div class="latest-events-holder">
<article>
<div class="image-text-group-a">
<a target="_blank" href="https://computingwebinars.evessiocloud.com/deskflixcloudinfrastructureoperations/en"><img alt="event logo" class="event-img" title="Cloud &amp; Infrastructure Operations" data-src="https://evessio.s3.amazonaws.com/customer/ba67648a-5a8b-4d5c-9ae6-00cb5850f2f7/event/6baa7bab-ad5e-49f0-a3e7-00500c80a387/media/media/CPTDF20-640x480_Thumbnail.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a title="Cloud &amp; Infrastructure Operations" target="_blank" href="https://computingwebinars.evessiocloud.com/deskflixcloudinfrastructureoperations/en">Cloud &amp; Infrastructure Operations</a>
</h5>
<p class="truncate-listing">
Tune in to Deskflix: Cloud and Infrastructure Ops to hear industry experts speak on the questions you need answered: how to formulate a coherent cloud strategy, what are the trade-offs between hybrid, private, public and on-prem, and how could a multi-cloud approach benefit your organisation?
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="09-09-2020">
<strong>Date:</strong> 09 Sep 2020
 </time>
</li>
<li>
</li>
</ul>
</div>
</article>
<article>
<div class="image-text-group-a">
<a target="_blank" href="https://event.computing.co.uk/devopsexcellence/en"><img alt="event logo" class="event-img" title="Computing DevOps Excellence Awards 2020" data-src="https://evessio.s3.amazonaws.com/customer/ba67648a-5a8b-4d5c-9ae6-00cb5850f2f7/event/0808913f-93fc-4a3a-9848-aaf8ea830805/media/media/DevOps_Excellence_Awards_stacked_loho_Thumbnail.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a title="Computing DevOps Excellence Awards 2020" target="_blank" href="https://event.computing.co.uk/devopsexcellence/en">Computing DevOps Excellence Awards 2020</a>
</h5>
<p class="truncate-listing">
Computing's DevOps Excellence Awards showcases outstanding achievement from organisations, personalities and solutions operating within the DevOps space.
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="15-10-2020">
<strong>Date:</strong> 15 Oct 2020
</time>
</li>
<li>
One Moorgate Place, London
</li>
</ul>
</div>
</article>
</div>
<div class="latest-events-holder">
<article>
<div class="image-text-group-a">
<a target="_blank" href="https://itleadersfestival.com/itleadersfestival/en"><img alt="event logo" class="event-img" title="IT Leaders Festival 2020" data-src="https://evessio.s3.amazonaws.com/customer/ba67648a-5a8b-4d5c-9ae6-00cb5850f2f7/event/6b7fb043-7a73-4163-bcdc-330e46e57cca/media/media/CPTLF2020-LOGO_256x256-01_Thumbnail.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a title="IT Leaders Festival 2020" target="_blank" href="https://itleadersfestival.com/itleadersfestival/en">IT Leaders Festival 2020</a>
</h5>
<p class="truncate-listing">
The inaugural IT Leader’s Festival is all about the experience of you and your team. Inspired by your peers, Computing has created a day that holds each individual at the core of the one-day event.
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="20-10-2020">
<strong>Date:</strong> 20 Oct 2020
</time>
</li>
<li>
Virtual,
</li>
</ul>
</div>
</article>
<article>
<div class="image-text-group-a">
<a target="_blank" href="https://event.computing.co.uk/AIML/en"><img alt="event logo" class="event-img" title="AI &amp; Machine Learning Awards 2020" data-src="https://evessio.s3.amazonaws.com/customer/ba67648a-5a8b-4d5c-9ae6-00cb5850f2f7/event/ba3c6180-73b4-4a97-989d-4df2251494a5/media/media/CTGAIMLA20-Logo-01_Thumbnail.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a title="AI &amp; Machine Learning Awards 2020" target="_blank" href="https://event.computing.co.uk/AIML/en">AI &amp; Machine Learning Awards 2020</a>
</h5>
<p class="truncate-listing">
The Computing AI &amp; Machine Learning Awards recognise the best companies, individuals, and projects in the AI space today. The awards cover every corner of the industry: security, ethics, data analysis, innovation and more, as well as showcasing the movers and shakers: the technology heroes and projects that deserve industry-wide praise.
The winners will be announced in London on 1 July 2020.
Entries are now open!
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="20-10-2020">
<strong>Date:</strong> 20 Oct 2020
</time>
</li>
<li>
TBC, London
</li>
</ul>
</div>
</article>
</div>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="https://www.computing.co.uk/events" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all events
</a>
</div>
</div>
</div>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-tab-panel main-top-hound" id="hound">
<a href="/resources" target="_blank">Whitepapers</a>
<ul class="menu-top-panel">
<li>
<div class="section group content">
<div class="col span-lrg_4_of_5">

<div class="col span-lrg_4_of_5"><header>
<div class="menu-top-panel-heading">LATEST WHITEPAPERS</div>
</header>
<section class="top-panel-paper">
<div class="image-text-group-a"><a href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener"><img src="/w-images/4bc47282-68f3-4dbf-beb1-d250cbdafe80/4/fill/Darktrace-120x194.jpg" alt="Darktrace 120x194" data-src="/w-images/4bc47282-68f3-4dbf-beb1-d250cbdafe80/4/fill/Darktrace-120x194.jpg" /></a></div>
<div class="image-text-group-b"><a href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener">Cyber AI Response: Threat Report 2019</a>
<p>This white paper details 7 case studies of attacks that were intercepted and neutralised by Darktrace cyber defense AI, including a zero-day trojan in a manufacturing company's network. Learn how Darktrace Antigena AI Response modules fight back autonomously, no matter where a threat may emerge, extending to the Cloud, Email and SaaS.</p>
<a class="btn download" href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener">Download</a></div>
</section>
<section class="top-panel-paper">
<div class="image-text-group-a"><a href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener"><img src="/w-images/6b3b22c4-9df7-4b8d-a268-d4a1bc07e8b1/4/fill/Darktrace-120x194.jpg" alt="Darktrace 120x194" data-src="/w-images/6b3b22c4-9df7-4b8d-a268-d4a1bc07e8b1/4/fill/Darktrace-120x194.jpg" /></a></div>
<div class="image-text-group-b"><a href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener">Cyber AI &amp; Darktrace Cloud</a>
<p>This white paper explores how cloud is a security blind spot for many organisations who struggle with the limited visibility and control in this new environment, where their existing security tools are often not applicable.</p>
<a class="btn download" href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$" target="_blank" rel="noopener">Download</a></div>
</section>
</div>
</div>
<div class="col span-lrg_1_of_5">
<section class="hound-search">
<header>
<div class="menu-top-panel-heading">Find whitepapers</div>
<div class="menu-top-panel-subheading">Search by title or subject area</div>
</header>
<aside>
<form target="_blank" name="multi" method="get" id="hound-search" enctype="multipart/form-data" action="/resources-search-results">
<input type="search" id="search-hound" placeholder="Search papers here" tabindex="1" required="" name="wpSearch">
<input type="hidden" value="computing" name="publisher">
<input type="submit" class="btn search-hound">
</form>
</aside>
</section>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="/resources" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all whitepapers
</a>
</div>
</div>
</div>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-tab-panel main-top-events" id="spotlight">
<a href="/spotlights" target="_blank">Spotlights</a>
<ul class="menu-top-panel">
<li>
<div class="section group content">

<div class="col span-lrg_3_of_3"><header>
<div class="menu-top-panel-heading">Spotlights</div>
</header>
<section class="top-spotlight">
<div class="image-text-group-b">
<p>Welcome to Computing's Spotlight section, where we focus in on particularly important themes and topics of enterprise IT.</p>
</div>
</section>
<section class="top-spotlight">
<div class="image-text-group-b">
<div class="image-text-group-b">
<figure class="tinymce-insert-asset-left"><img src="/api/v1/wps/20ffa97/d367145c-5552-4321-a768-8c05e4992982/1/intel-logo-2-200x134.png" height="134" width="200" alt="Intel logo" />
<figcaption></figcaption>
</figure>
<p>&nbsp;</p>
<h3 id="mcetoc_1eahpt7070"><a href="https://www.computing.co.uk/content-hub/4015377/endpoint-management-security-hub-introducing-intel-vpro-platform">Endpoint Management and Security Hub</a></h3>
</div>
</div>
</section>
</div>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-tab-link main-top-fundcentre">
<a href="/series/profile/delta-top-250-uk-it-leaders">IT Leaders 250</a>
</li>
<li class="main-top-title main-top-tab-link main-top-fundcentre">
<a href="/research">Research</a>
</li>
<li class="main-top-title main-top-investment-europe">
<a href="https://www.computingdelta.com/?utm_source=computing&amp;utm_medium=link&amp;utm_campaign=computing_commerical_nav">Delta</a>
</li>
<li class="main-top-title main-top-investment-europe">
<a href="/tag/tech-marketing-hub">Tech Marketing Hub</a>
</li>
<li class="main-top-title main-top-tab-link main-top-advertise">
<a href="/computing-about-us?utm_source=computing&amp;utm_medium=commercial_navigation&amp;utm_campaign=about_us">About Us</a>
</li>
</ul>
</nav>
<header role="banner" class="main-head">
<div class="main-head-content content-width">
<div class="site-header">
<div class="site-logo-holder" itemscope itemtype="https://schema.org/Organization">
<div itemprop="name" class="screen-reader-text">
Computing
</div>
<a href="/" title="Return to homepage" class="site-logo"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="Computing" class="sprite"></a>
</div>
<div class="search-1 header-search-holder blur">
<form id="search_form_bottom" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" data-disable-with="" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>
</div>
</div>
</header>
<nav class="nav">
<div class="holder">
<div class="hamburger-style" id="nav-toggle" aria-label="Menu">
<span></span>
</div>
<div class="clicker4" aria-label="Login"></div>
<script type="text/conditional-html" id="tablet-conditional-navigation">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</script>
<div id="conditional-navigation" class="">
<nav class="primary-nav nav-colour01" role="navigation" aria-label="Primary">
<ul class="main-menu main-top-content content-width">
<li class="menu-title">
<a title="" href="/">Home</a>
</li>
<li class="menu-title">
<a title="" href="/type/news">News</a>
</li>
<li class="menu-title">
<a title="" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
</li>
<li class="menu-title">
<a title="" href="/category/devops">DevOps</a>
</li>
<li class="menu-title">
<a title="" href="/category/security">Security</a>
</li>
<li class="menu-title">
<a title="" href="/tag/gdpr">GDPR</a>
</li>
<li class="menu-title">
<a title="" href="/tag/artificial-intelligence">AI &amp; ML</a>
</li>
<li class="menu-title">
<a title="" href="/tag/women-in-tech-festival">Women in Tech</a>
</li>
<li class="menu-title">
<a title="" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
</li>
<li class="menu-title">
<a title="" href="/tag/cio">CIO</a>
</li>
<li class="menu-title">
<a title="" href="/deskflix">Deskflix</a>
</li>
</ul>
</nav>
</div>
<div class="mobile-branding"><a href="/" class="mobile-branding-link" alt="Computing"></a></div>
</div>
<div class="mask">
<div class="menu4">
<div>
<a href="/manage_account#myaccount" class="user-info"></a>

<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu">
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>

<li><a class="account-user-link" title="Account details" href="/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>

<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a title="Sign in" href="/userlogin">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a class="sign-in-user-link" title="Sign in" href="/userlogin">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>
</div>
</div>
</div>
</nav>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-below-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="page-content ajax_search">
<header class="article-header" style="background-image:url('/api/v1/wps/aec2370/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-1842x720.jpg');">
<div class="content">
<div class="content-inner">
<div class="main-content">
<div class="section group">
<div class="col span_1_of_5">
<nav>
<ul class="meta-taxonomy-list breadcrumb">
<li>
<a href="/category/software/developer">Developer</a>
</li>
</ul>
</nav>
</div>
<div class="col span_4_of_5">
<h1 itemprop="name" class="article-title">Behind the scenes at the BBC&#39;s groundbreaking Own It app</h1>
<h2 class="article-sub-title">App designed to safeguard children online was the result of two years' toil at AI's cutting edge, says product manager Jon Howard</h2>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="content">
<main role="main" class="content-inner">
<div class="main-content">
<article class="section group article">
<div class="col span_1_of_5"></div>
<div class="col span_4_of_5 article-col">
<div class="article-meta-container group">

<ul class="meta-taxonomy-list author-dateline ">
<li class="author-dateline-image">
<a title="John Leonard" href="/author/7b3ab8a6-1a19-4ddf-9eba-1988b2ba8d86/john-leonard"><img class="author-pic" alt="John Leonard" src="/api/v1/wps/6c1f168/7b414827-13ce-45c0-ad09-51eb14049552/0/jleonard1-100x100.jpg" /></a>
</li>
<li class="author-dateline-name">
<a href="/author/7b3ab8a6-1a19-4ddf-9eba-1988b2ba8d86/john-leonard">John Leonard</a>
</li>
<li class="author-dateline-social">
<div class="meta-twitter">
<a class="twitter-follow" target="_blank" data-component="meta-twitter-handle" data-link-name="twitter-handle" href="https://twitter.com/@_JohnLeonard">
<svg viewBox="0 0 15 12" height="0.813em" width="0.938em" y="0" x="0" class="twitter-icon">
<path d="M15,1.422c-0.541,0.241-1.128,0.404-1.74,0.477c0.625-0.376,1.106-0.969,1.331-1.678
							c-0.584,0.347-1.235,0.602-1.924,0.737c-0.555-0.59-1.342-0.956-2.21-0.956c-1.675,0-3.03,1.354-3.03,3.028
							c0,0.236,0.027,0.468,0.077,0.692C4.986,3.594,2.756,2.39,1.262,0.556C1.001,1.002,0.851,1.522,0.851,2.078
							c0,1.051,0.536,1.977,1.348,2.521C1.702,4.582,1.237,4.446,0.828,4.222c0,0.013,0,0.025,0,0.037c0,1.467,1.043,2.691,2.429,2.971
							C3.003,7.297,2.735,7.334,2.459,7.334c-0.196,0-0.387-0.018-0.57-0.052c0.384,1.204,1.502,2.078,2.83,2.102
							c-1.035,0.813-2.343,1.299-3.76,1.299c-0.247,0-0.487-0.015-0.726-0.044C1.574,11.498,3.167,12,4.879,12
							c5.571,0,8.616-4.616,8.616-8.618c0-0.13,0-0.263-0.006-0.393C14.08,2.562,14.592,2.031,15,1.422z" />
</svg>
<div class="contact">
@_JohnLeonard
</div>
</a>
</div>
</li>
<li class="author-dateline-time">
<time datetime="2020-07-30" itemprop="datePublished">
30 July 2020
</time>
</li>
</ul>
<div class="tools-meta-outer">
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=Behind+the+scenes+at+the+BBC%27s+groundbreaking+Own+It+app&amp;url=https://www.computing.co.uk/4018405/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/4018405" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
<span class="screen-reader-text">LinkedIn</span>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/4018405&amp;title=Behind+the+scenes+at+the+BBC%27s+groundbreaking+Own+It+app" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="mailto:?subject=Behind the scenes at the BBC&amp;#39;s groundbreaking Own It app&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F4018405">&nbsp;</a>
</div>
</li>
</ul>
<div class="article-meta-numbers">
<div class="comment-count">
<a href="https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app#disqus_thread">0 Comments</a>
</div>
<div class="social-count">
<a href="/feature/4018405/scenes-bbc-groundbreaking-app"><span class="share-total"></span></a>
</div>
</div>
</div>
</div>
<div id="rdm-below-summary"></div>
<div class="article-page-body-content">
<p>The BBC is in a unique position when it comes to developing AI, says Jon Howard, executive product manager children's future media at the broadcaster.&nbsp;</p>
<p>Large enough to make the most of relationships with the tech giants working at the cutting edge of the craft like Apple and Google's TensorFlow engineers, its remit also enables the broadcaster to step into areas frequently neglected by VC-funded start-ups.</p>
<div id="rdm-above-related"></div>
<p>When looking at ways to tackle the epidemic of online bullying and childhood mental health problems related to living life on screen, Howard's team asked 50 parents and 50 children what they'd like to see in an app dedicated to children's' wellbeing. The parents universally wanted a monitoring app while the children universally did not, so that was that. In any case, there are already plenty of parental monitoring apps, said Howard, because that's where the money is, but there was nothing to help children to manage their own experiences on social media and the wider online world.</p>
<p>"We saw this as a key space where the BBC could help out," said Howard (<em>pictured</em>), speaking to <em>Computing</em> after the Deskflix Public Sector event where he delivered a keynote presentation. "Here's where our public service principles could play their part."</p>
<h3 id="mcetoc_1eee0nep90">New worlds</h3>
<p>Many kids receive their first smartphone between the ages of 8 and 12 and become active on social media, entering a world governed by a very different set of rules, norms and expectations. It's a time of life when they are exploring new horizons, and unlike in the physical world where a disapproving glance from an adult is enough to tell them they may be acting inappropriately, cyberspace offers little in the way of guardrails.</p>
<p>Children's charity NSPCC has registered a sharp rise in referrals to mental health services, some of which is related to the use of social media. The BBC's <a href="https://www.bbc.com/ownit/take-control/own-it-app" target="_blank" rel="noopener">Own IT</a> app seeks to replace the adult in the room with an AI in the phone, an advisor who can warn the child that the message they're about to send may be hurtful to the recipient, or that sending their phone number to a new contact may not be a good idea.&nbsp;</p>
<p>Own It is a keyboard for iOS and Android plus a companion app that enables the user to record their feelings. Designed in consultation with child psychologists, the Turing Institute and Public Health England, the idea is to help children to better understand their behaviour online and its effect on others, and to navigate the new world safely. It adopts a &lsquo;nudge' approach rather than being proscriptive and is focused purely on output - what children are saying rather than what they're seeing. In this way, it can work in conjunction with monitoring apps if parents insist.</p>
<h3 id="mcetoc_1eee0nomf1">You say it you own it</h3>
<p>The product of two years' development work, the Own It keyboard deploys machine learning models to support autocorrect, autocomplete and next-word-prediction functions based on how children really communicate online. In this, it works in a similar way to Google's GBoard keyboard, but using kids' vocabulary. But there's also a proactive element: start typing a message with &lsquo;I hate you&hellip;' and the guardrails kick in. The UI border turns red and a worried-looking emoticon pops up with a message "How would you feel if someone sent you that?" The keyboard does not stop the hateful message being sent because Own It is about encouraging children to be responsible for their own behaviour, offering guidance rather than policing. Instead it prompts the user to try a different set of words until a happy face and calm blue border appears.</p>
<p>"Kids generally want to be good, they generally want to be nice people," said Howard. "We won't stop them sending a message, we just provide a bit of friction."</p>
<figure class="tinymce-insert-asset-center"><img src="/api/v1/wps/b9bdd36/816cc3ab-e5c4-4ef9-802c-992ff935b272/24/bbc-own-it-keyboard-720x334.png" alt="Own It keyboard. Source: BBC" width="720" height="334" border="0" />
<figcaption>Own It keyboard</figcaption>
</figure>
<p>The companion app, meanwhile, allows the user to keep a private record of their thoughts and feelings, which has been shown to be an effective psychological approach to combating stress.</p>
<p>The app has won many plaudits, including a CogX award for best innovation in natural language processing (NLP), a UXUK gong for best design for education, and a Banff World Media award for best interactive content for young people, plus there's been international interest from other publishers and broadcasters.</p>
<p>"A lot of people are taking notice", Howard said.</p>
<div class="longform-billboard"></div>
<p>Own it was developed by ten BBC product and project managers, technical architects and UX and editorial content producers who worked with five engineers from Swiss consultancy Privately to develop an SDK containing the machine learning, AI and business logic, and a similar number from Glasgow-based UX specialists Chunk Digital. Other specialists and consultants were brought in as the needs arose, including Apple and Google engineers - who were consulted to ensure the app would work cross-platform with only one development workflow - child psychologists and experts in AI ethics.</p>
<p>"As much as possible we tried to work as a single team, ensuring that communications were constant and dependencies were tightly managed," said Howard.</p>
<h3 id="mcetoc_1eee0og1i2"><strong>Keeping up with the yeets</strong></h3>
<p>The app's functionality is simple, intentionally so, but this simplicity is the result of a great deal of research, experimentation and the jettisoning of many a bell and a whistle.</p>
<p>Howard's team encountered a number of tricky challenges as they developed the MVP, the first of which was the lack of any coherent dataset on the way young people speak online with which to train the machine learning models. A core dictionary had to be painstakingly pieced together by analysing young peoples' messages on social media and comparing word frequencies and usage with adult equivalents.</p>
<blockquote>
<p>The way new words arrive is absolutely fascinating</p>
</blockquote>
<p>And of course, language doesn't stand still. Howard mentions yeet, a word meaning <a href="https://www.youtube.com/watch?v=tp3sWVBNz30">to forcefully throw away</a>, which suddenly became popular after a Vine video of a kid dancing and then another featuring a girl hurling a can of soda while yelling &lsquo;yeet!' went viral. New words can spring up on social media anywhere in the world and become part of the global lexicon within a few short months, sometimes with local variants. Incidentally, the <em>Urban Dictionary</em> shows that yeet peaked in 2019 and is now, presumably, being used ironically by the cool kids. The app's models need to be able to keep up with nuanced changes like these, or it will find itself yeeted.</p>
<p>"The way new words arrive is absolutely fascinating," Howard said. "I went off on a massive track of learning all about this stuff, building glossaries and then taking words that have just been introduced by children and refining the models."</p>
<h3 id="mcetoc_1eee0rcl73"><strong>Neutral territory</strong></h3>
<p>Then there was the perennial problem of data-driven bias in machine learning models. Own It deploys four models designed to recognise hate, toxicity, emotion sentiment and emotion, which it uses to decide on the appropriateness of a message. But during development the team uncovered a number of areas where it overreacted or made a mistake. For example, a message beginning &lsquo;Men are..' would cause the concerned face and red border to immediately pop up before any qualifying words were added. To tackle this issue, the team replaced certain gender-, religion- and ethnicity-specific terms with &lsquo;neutral' and were surprised at the results.</p>
<div class="longform-hpu"></div>
<p>"That was a really simple trick and we thought this is never going to work, but it worked really well and it was way better than before," Howard said.&nbsp;&nbsp;</p>
<h3 id="mcetoc_1eee0rnsg4"><strong>The privacy conundrum</strong></h3>
<p>Trust is all-important with an app like this, and Own It adheres strictly to all the principles of <a title="privacy-by-design-an-idea-whose-time-has-come" href="https://www.computing.co.uk/feature/2428799/privacy-by-design-an-idea-whose-time-has-come" target="_blank" rel="noopener">Privacy by Design</a>. No information that might identify the user or the device is collected or stored, and all messages are deleted from the keyboard as soon as they have been sent.</p>
<p>Great, but for a machine learning app this presents a problem: how to integrate feedback to improve the models?</p>
<p>For now, this is a semi-manual process using the feedback provided by users, for example a&nbsp; complaint when a warning has been shown during casual friendly banter, to pinpoint areas for improvement. That information is then used to source better data to cover the problem areas. Differential privacy techniques will eventually solve these problems, but they are not ready for the primetime just yet.</p>
<figure class="tinymce-insert-asset-center"><img src="/api/v1/wps/973eade/69975610-6763-4c61-90d5-99889605b15d/24/bbc-own-it-companion-app-720x335.png" alt="bbc Own It companion app. Own It keyboard. Source: BBC" width="720" height="335" border="0" />
<figcaption>Own It companion app</figcaption>
</figure>
<h3 id="mcetoc_1eee0s75m5"><strong>3.5 billion into 15 million will go</strong></h3>
<p>In line with its privacy-preserving credentials, Own It is completely decentralised. Its functions are fully encapsulated on the device and it does not communicate with the models in the cloud. This design presented another major challenge: the 3.5GB machine learning models were far too large for a smartphone app. So, Howard's team got to work whittling it down to size. Using a variety of methods including FastText compression and shaving off a few model layers they succeeded in shrinking the 3.5GB to 40mb, and with further attention to the data reduced the final ML ensemble still further to a mere 15mb, with accuracy actually improved by making the machine learning less generic more specific.</p>
<div class="longform-billboard"></div>
<p>The result is a package that can be easily updated over the air every few weeks, which is frequent enough even to keep up with the rapid flow of teen memes and text-speak.</p>
<blockquote>
<p id="mcetoc_1eee0t0366">We were at the cutting edge 18 months ago</p>
</blockquote>
<h3 id="mcetoc_1eee0tlul7"><strong>What's next?</strong></h3>
<p>NLP is improving at an exponential rate. "We were at the cutting edge 18 months ago" quipped, Howard, adding that the team is constantly reviewing new developments to see how they might be incorporated, including differential privacy techniques - which would allow models to learn from anonymous user data without the danger of de-anonymisation - and federated learning, in which changes in weights and biases are synchronised between on-device and cloud models. The latter would ultimately allow some of the machine learning training to be performed on the smartphone rather than in the cloud, something Google is already doing with Gboard: "It's really interesting and Google are nailing it now," said Howard.</p>
<p>Another area Howard is keeping an eye on is synthetic data, deploying text-generating neural networks like OpenAI's GPT-2 and the latest <a href="https://thenextweb.com/neural/2020/07/23/openais-new-gpt-3-language-explained-in-under-3-minutes-syndication/" target="_blank" rel="noopener">GPT-3</a>, which is currently making headlines for its ability to generate meaningful and contextually appropriate sentences with only very small example sets to work from. Models like these could be used to fill in gaps in the data, currently a manual process. "If you give these models some of our phrases they churn out terms which are like them. Experimentally we've found they're really good."</p>
<p>As well as rounding out the data set, such models can also be used to check for their own biases too.</p>
<p>Future iterations will be informed by the results of ongoing efficacy tests by Manchester University which are expected to conclude in the next few of months. The team is also developing an efficacy framework to gauge the effectiveness of Own It in helping children make the most of what the web has to offer while avoiding the pitfalls.</p>
<p>"It's about finding out which interventions are most effective and how best to present them," Howard said.&nbsp;</p>
<p><em>Jon Howard will be speaking at </em>Computing<em>'s IT Leaders Festival 2020 - <a title="IT Leaders 2020" href="https://www.itleadersfestival.co.uk/itleadersfestival/en/page/home?utm_source=computing&amp;utm_medium=article&amp;utm_campaign=BBCapp   " target="_blank" rel="noopener"><strong>register today</strong></a>!</em></p>


<div id="rdm-below-article-body"></div>
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=Behind+the+scenes+at+the+BBC%27s+groundbreaking+Own+It+app&amp;url=https://www.computing.co.uk/4018405/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/4018405" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
<span class="screen-reader-text">LinkedIn</span>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/4018405&amp;title=Behind+the+scenes+at+the+BBC%27s+groundbreaking+Own+It+app" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="mailto:?subject=Behind the scenes at the BBC&amp;#39;s groundbreaking Own It app&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F4018405">&nbsp;</a>
</div>
</li>
</ul>
<ul class="meta-taxonomy-list related-links">
<li>
Topics
</li>
<li>
<a category="#&lt;SiteMetaDataProxy:0x007fdd42257228&gt;" href="/category/software/developer">Developer</a>
</li>
<li>
<a category="#&lt;SiteMetaDataProxy:0x007fdd42256800&gt;" href="/category/software">Software</a>
</li>
<li>
<a category="#&lt;SiteMetaDataProxy:0x007fdd42255d88&gt;" href="/category/communications/mobile">Mobile</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421b88d0&gt;" href="/tag/bbc">BBC</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421b8218&gt;" href="/tag/apple">Apple</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c3aa0&gt;" href="#">Google</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c34b0&gt;" href="/tag/nspcc">NSPCC</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c2e20&gt;" href="/tag/chunk-digital">Chunk Digital</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c2790&gt;" href="/tag/ai">ai</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c2150&gt;" href="/tag/machine-learning">machine learning</a>
</li>
<li>
<a tag="#&lt;SiteMetaDataProxy:0x007fdd421c1a70&gt;" href="/tag/artificial-intelligence">Artificial Intelligence</a>
</li>
</ul>
</div>
</div>
</article>
<div id="rdm-above-series-blog"></div>
<div id="rdm-above-related"></div>
<div id="rdm-above-more-news"></div>

<section class="news-articles">
<header class="related-listings-header">
<h4 itemprop="name">More on Developer</h4>
</header>
<div class="section group">
<article class="col span_2_of_4 first-element">
<div class="image-text-group-a">
<a href="/news/4018265/ai-model-identify-birds"><img alt="Researchers have trained an AI model to re-identify birds in new images" title="Researchers have trained an AI model to re-identify birds in new images" src="/api/v1/wps/3a1bb83/f470d7ef-6800-4fcc-bab3-b282f392de30/4/bird-230x142.jpg" /></a>
</div>
<div class="image-text-group-b ">
<h5 class="listings-article-title"><a href="/news/4018265/ai-model-identify-birds">Artificial intelligence model trained to identify birds in new images</a></h5>
<p class="section-story">
Artificial intelligence could help researchers in studying avian behaviour
</p>
<ul class="article-meta-details">
<li>
<a class="-link" href="/category/software">Software</a>
</li>
<li>
<time datetime="2020-07-27" itemprop="datePublished">
27 July 2020
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4 ">
<div class="image-text-group-a">
<a href="/news/4017203/ordnance-survey-free-access-mastermap-location"><img alt="Ordnance Survey provides free access to OS MasterMap location data" title="Ordnance Survey provides free access to OS MasterMap location data" src="/api/v1/wps/e1261d9/3b95e634-3434-4dd7-b338-5c4131742a7b/1/bennevis-230x142.jpg" /></a>
</div>
<div class="image-text-group-b ">
<h5 class="listings-article-title"><a href="/news/4017203/ordnance-survey-free-access-mastermap-location">Ordnance Survey opens up free access to OS MasterMap location data</a></h5>
<p class="section-story">
OS DataHub includes a number of new mapping data products and APIs for developers
</p>
<ul class="article-meta-details">
<li>
<a class="-link" href="/category/software">Software</a>
</li>
<li>
<time datetime="2020-07-01" itemprop="datePublished">
01 July 2020
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4 ">
<div class="image-text-group-a">
<a href="/feature/4017118/at2-answer-cryptocurrency-energy-performance"><img alt="Asynchronous Trustworthy Transfers: the missing link?" title="Asynchronous Trustworthy Transfers: the missing link?" src="/api/v1/wps/b7614b1/96860f32-cf87-4730-a059-c2078eb3721a/2/chain-foundry-iStock-469874983-230x142.jpg" /></a>
</div>
<div class="image-text-group-b ">
<h5 class="listings-article-title"><a href="/feature/4017118/at2-answer-cryptocurrency-energy-performance">Could AT2 be the answer to cryptocurrency&#39;s energy and performance problems?</a></h5>
<p class="section-story">
Blockchains are slow, wasteful and ill-suited for digital currencies, say researchers who believe they&#39;ve found a better way
</p>
<ul class="article-meta-details">
<li>
<a class="-link" href="/category/software/developer">Developer</a>
</li>
<li>
<time datetime="2020-06-30" itemprop="datePublished">
30 June 2020
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4 ">
<div class="image-text-group-a">
<a href="/news/4017084/github-developers-world"><img alt="" title="" src="/api/v1/wps/9a6f7bd/32651ef1-de69-4519-a07e-58dca6ece815/5/github-universe-230x142.jpg" /></a>
</div>
<div class="image-text-group-b ">
<h5 class="listings-article-title"><a href="/news/4017084/github-developers-world">GitHub is down for developers across the world</a></h5>
<p class="section-story">
GitHub says it has found the problem and is working to resolve it.
</p>
<ul class="article-meta-details">
<li>
<a class="-link" href="/category/software/developer">Developer</a>
</li>
<li>
<time datetime="2020-06-29" itemprop="datePublished">
29 June 2020
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4 ">
<div class="image-text-group-a">
<a href="/opinion/4017065/technology-design-principles-combat-domestic-abuse"><img alt="" title="" src="/api/v1/wps/aa9ce77/9b5a686d-ec64-486c-8db1-fc1f50da97c6/1/sad-woman-silhouette-window-iStock-1181078647-230x142.jpg" /></a>
</div>
<div class="image-text-group-b ">
<h5 class="listings-article-title"><a href="/opinion/4017065/technology-design-principles-combat-domestic-abuse">Five technology design principles to combat domestic abuse</a></h5>
<p class="section-story">
Measures technologists can take to ensure the products they create are resistant to coercive control
</p>
<ul class="article-meta-details">
<li>
<a class="-link" href="/category/software/developer">Developer</a>
</li>
<li>
<time datetime="2020-06-29" itemprop="datePublished">
29 June 2020
</time>
</li>
</ul>
</div>
</article>
</div>
</section>
<div id="rdm-above-comments"></div>
<section class="comment">
<div>
<div class="list-holder">
<div class="list-inner">
<div id="disqus_thread"></div>
<script>
            /**
             *  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
             *  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
            var disqus_config = function () {
                this.page.url = "https://www.computing.co.uk/feature/4018405/scenes-bbc-groundbreaking-app";  // Replace PAGE_URL with your page's canonical URL variable
                this.page.identifier = '/feature/4018405/scenes-bbc-groundbreaking-app'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
            };

            var disqus_shortname = 'computing-live';

				</script>
<noscript>
					Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a>
				</noscript>
<a href="https://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
</div>
</div>

</div>
</section>
<div class="scrollup">
Back to Top
</div>
</div>
<div role="complementary" class="sidebar">
<div id="rdm-rhc-top" class="ad-slot"></div>

<section class="popular-articles">
<header class="related-listings-header">
<h4 itemprop="name">
<div class="section-title-link">
Most read
</div>
</h4>
</header>
<div class="section group">
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/opinion/4018316/deal-zoom"><img alt="Why you should never say &#39;that&#39;s a deal&#39; on Zoom " src="/api/v1/wps/cd0752b/d6c357ba-693f-4794-9549-8c925f39962e/1/john-warchus-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Why you should never say &#39;that&#39;s a deal&#39; on Zoom " href="/opinion/4018316/deal-zoom">Why you should never say &#39;that&#39;s a deal&#39; on Zoom </a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/news/4018349/blackbaud-hack-national-trust-confirms-breach"><img alt="Blackbaud hack: National Trust confirms data breach" src="/api/v1/wps/a40c82a/c8648c46-ba4c-40ec-9c62-4ae378086b50/3/National-Trust-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Blackbaud hack: National Trust confirms data breach" href="/news/4018349/blackbaud-hack-national-trust-confirms-breach">Blackbaud hack: National Trust confirms data breach</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/feature/4018405/scenes-bbc-groundbreaking-app"><img alt="Behind the scenes at the BBC&#39;s groundbreaking Own It app" src="/api/v1/wps/61adb22/f0bf96cf-e9f6-4dac-850d-8cca15fadf88/3/jon03-tedx-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Behind the scenes at the BBC&#39;s groundbreaking Own It app" href="/feature/4018405/scenes-bbc-groundbreaking-app">Behind the scenes at the BBC&#39;s groundbreaking Own It app</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/news/4018266/uk-firm-reaches-final-stages-nist-quest-quantum-proof-encryption-algorithms"><img alt="UK firm reaches final stages of the NIST quest for quantum-proof encryption algorithms" src="/api/v1/wps/1b77e7b/d9cd4724-5356-41c9-ad82-e4c38ec8f3d0/7/AndersenCheng-Photo-1-280815a-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="UK firm reaches final stages of the NIST quest for quantum-proof encryption algorithms" href="/news/4018266/uk-firm-reaches-final-stages-nist-quest-quantum-proof-encryption-algorithms">UK firm reaches final stages of the NIST quest for quantum-proof encryption algorithms</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/news/4018299/major-hedge-fund-customers-personal-stolen-hackers"><img alt="Major hedge fund sees customers&#39; personal data stolen by hackers" src="/api/v1/wps/56ebcc0/b9ef45a4-6230-49f6-a653-269c95ebeb6f/3/ransomware-attack-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Major hedge fund sees customers&#39; personal data stolen by hackers" href="/news/4018299/major-hedge-fund-customers-personal-stolen-hackers">Major hedge fund sees customers&#39; personal data stolen by hackers</a>
</h5>
</div>
</article>
</div>
</section>
<div id="rdm-rhc-bottom" class="ad-slot"></div>
</div>
</main>
</div>
</div>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-footer" class="ad-slot-full"></div>
</div>
</div>
</aside>
<footer class="main-footer">
<div class="main-footer-content main-footer-links">
<div class="main-footer-content-inner content-width">

<ul class="main-footer-nav">
<li class="menu-title"><a title="Contact us" href="/contacts">Contact</a></li>
<li class="menu-title"><a title="Delta" href="https://www.computingdelta.com/">Delta</a></li>
<li class="menu-title"><a title="Marketing solutions" href="http://btgmarketingsolutions.incisivemedia.com/">Marketing solutions</a></li>
<li class="menu-title"><a title="Enterprise IT Events" href="http://www.enterpriseitevents.com/">Enterprise IT Events</a></li>
<li class="menu-title"><a title="About Incisive Media" href="http://www.incisivemedia.com/our-story/" target="_blank" rel="noopener noreferrer">Incisive Media</a></li>
<li class="menu-title"><a title="Terms and conditions" href="http://www.incisivemedia.com/terms-conditions/" target="_blank" rel="noopener noreferrer">Terms &amp; conditions</a></li>
<li class="menu-title"><a title="Policies" href="https://www.incisivemedia.com/terms-conditions/#policies" target="_blank" rel="noopener noreferrer">Policies</a></li>
<li class="menu-title"><a title="Careers" href="https://www.incisivemedia.com/our-careers/?utm_source=computing&amp;utm_medium=footer_navigation&amp;utm_campaign=corporate_careers_links" target="_blank" rel="noopener noreferrer">Careers</a></li>
</ul>
<ul class="footer-tools-content main-footer-align-right">
<li>
<div class="nav-tools twitter-icon">
<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
</div> </li>
<li>
<div class="nav-tools linkedin">
<a href="https://www.linkedin.com/showcase/computing--/" target="_blank">LinkedIn</a>
</div> </li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</div> </li>
<li>
<div class="nav-tools facebook-icon">
<a href="https://www.facebook.com/ComputingUK" target="_blank">Facebook</a>
</div> </li>
<li>
<div class="nav-tools youtube">
<a href="https://www.youtube.com/playlist?list=PL2k5gwH-ELDedgZlV4iYGTMJKMvzSLKEA" target="_blank">YouTube</a>
</div> </li>
</ul>
</div>
</div>
<div class="main-footer-content main-footer-copyright">
<div class="main-footer-content-inner content-width">

<div class="incisivemedia-footer">
<p class="corp-logo" style="float: left; padding: 0px 10px 0px 5px;"><a title="Incisive Media" href="https://www.incisivemedia.com/" target="_blank" rel="noopener noreferrer"><img src="https://assets.computing.co.uk/production/global/images/im_logo.png" alt="im_logo" width="130" height="85" /></a></p>
<p class="copyright-full">&copy; Incisive Business Media (IP) Limited, Published by Incisive Business Media Limited, New London House, 172 Drury Lane, London WC2B 5QR, registered in England and Wales with company registration numbers 09177174 &amp; 09178013</p>
</div>
<div class="incisivemedia-accreditation">
<div class="accredit-text"><a href="http://www.incisivemedia.com/accreditations" target="_blank" rel="noopener noreferrer">Digital publisher of the year</a></div>
<div class="accreditation-logos"><span class="screen-reader-text">Digital publisher of the year 2010, 2013, 2016 &amp; 2017</span></div>
</div>
</div>
</div>
</footer>
</div>
<script src="//assets.kreatio.net/Incisive_live/Computing/javascripts/computing.min2.js"></script>
<script>
    jQuery(document).ready(function() {
        if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
            var userlogin_path=location.pathname;
            if(userlogin_path == "/userlogin"){
                $("span#login_error_message_header").html(getCookie("series_token_error_message").replace(/\+/g, " ")).show();
                deleteCookie("series_token_error_message");
            }}});
    jQuery(document).ready(function() {
        $("#userlogin .btn.login").on("click",function(){
            $("span#login_error_message_header").html("").hide();
        })});
</script>
<script>
    jQuery(document).ready(function() {
        if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
            if(getCookie("series_token_error_message").match("articles$") !=null){
                $("span#login_error_message_teaser").html(getCookie("series_token_error_message").replace(/\+/g, " ").replace(/\w+$/,'')).show();
                deleteCookie("series_token_error_message");
            }
        }
    });
    jQuery(document).ready(function() {
        $("#login_barrier .login_submit").on("click",function(){
            $("span#login_error_message_teaser").html("").hide();
        });});
    function custom_method_for_search_image(){
        image_value='';
        return image_value;
    }
</script>
<script src="//assets.computing.co.uk/cdn/ctg/scripts/scripts.js"></script>
<script type="text/javascript">
    jQuery(document).ready(function() {
        $("#login").hover(function() {
            $(".login-offset").hide();
        });

        function showMyAccount() {
            $(".individual").show();
            $('.institutional').hide();
            $(".user-info").html('My account');
            $("#user").removeClass("main-top-institution");
        }

        function showWelcome() {
            $("#login").hide();
            $("#register").hide();
            $("#user").show();
            $(".user-info").html('Welcome');
            $("#user").addClass("main-top-institution");
        }

        setTimeout(function() {
            jQuery("#register,#login,#follow,#free-trial").show();
            if (getCookie("logged_in") == "false" || (getCookie("institutional_login") == "false")) {
                jQuery("#register,#login,#follow,#free-trial").show();
                jQuery("#user").hide();
            } else if (getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" || getCookie("logged_in") == null) {
                if (getCookie("user_name") != null && getCookie("user_name") != "") {

                    $("#user,#follow").show();
                    $("#register,#login,#free-trial").hide();
                    jQuery(".user-info").html('My account');
                    if (getCookie("institutional_login") == "true") {
                        if (getCookie("logged_in") == "true") {
                            showMyAccount()
                        } else {
                            showWelcome()
                        }
                    } else {
                        if (getCookie("logged_in") == "true") {
                            showMyAccount()
                        }
                    }
                } else {
                    jQuery.ajax({
                        type: 'GET',
                        dataType: 'html',
                        beforeSend: function(xhr) {
                            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'))
                        },
                        url: '/user_info',
                        success: function(data) {
                            if (getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" || getCookie("logged_in") == null) {
                                if (getCookie("user_name") != null && getCookie("user_name") != "") {
                                    $("#user,#follow").show();
                                    $("#register,#login,#free-trial").hide();
                                    jQuery(".user-info").html('My account');
                                    if (getCookie("institutional_login") == "true") {
                                        if (getCookie("logged_in") == "true") {
                                            showMyAccount()
                                        } else {
                                            showWelcome()
                                        }
                                    }
                                } else if (getCookie("institutional_login") == "true") {
                                    if (getCookie("logged_in") == "true") {
                                        showMyAccount()
                                    } else {
                                        showWelcome()
                                    }
                                }
                            } else {
                                $("#register,#login,#follow,#free-trial").show();
                            }
                        }
                    });
                }
            }
        }, 1000);
        $("#user").hover(function(event) {
            event.preventDefault();
            if (getCookie("institutional_login") == "true") {
                if (getCookie("logged_in") == "true") {
                    $(".individual").show();
                    $('.institutional').hide();
                } else {
                    $(".individual").hide();
                    $('.institutional').show();
                }
            } else {
                if (getCookie("logged_in") == "true") {
                    $(".individual").show();
                    $('.institutional').hide();
                }
            }
        });
    });
</script>
<script>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</script>
<script>
      /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
      var disqus_shortname = 'computing-live'; // required: replace example with your forum shortname
      var disqus_identifier = "/feature/4018405/scenes-bbc-groundbreaking-app";
      /* * * DON'T EDIT BELOW THIS LINE * * */
      (function () {
          var s = document.createElement('script');
          s.async = true;
          s.type = 'text/javascript';
          s.src = '//computing-live.disqus.com/count.js';
          (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
      }());
  </script>
<script>
      $(document).ready(function(){
          var currentBlock = location.href.split('#')[1];
          if(currentBlock != undefined){
              pageScroll(currentBlock);
          }
      });

      $('.article-page-body-content li a').on('click',function(){

          pageScroll($(this).attr('href').split('#')[1]);

      });
      function pageScroll(currentLink){
          var height = '47';
          var $winWidth = $(window).width();
          if($winWidth > 991){
              $('html,body').animate({scrollTop: $('#'+currentLink).offset().top-height},'slow');
          }
          else{
              $('html,body').animate({scrollTop: $('#'+currentLink).offset().top-50},'slow');
          }
      }
  </script>
<script src="//assets.computing.co.uk/javascript/live/computing/javascript-computing.body.min.js"></script>
<script>
    $(document).ready(function(){
        if($('.remote_component').length > 0 ){

            $(".remote_component").each(function() {
                var id = $(this).attr('id');
                var page_id = $(this).attr('data_page_id');

                $.ajax({
                    type: 'get',
                    dataType: 'html',
                    url: '/get_remote_component',
                    data: {id: id ,page_id: page_id},
                    beforeSend: function (xhr) {
                        xhr.setRequestHeader('X-CSRF-Token', $('meta[name="csrf-token"]').attr('content'))
                    },
                    success: function (data) {
                        $('#'+id).html(data)
                    }
                });

            });
        }
    });
</script>
<div class="kreatio-mostread" style="display:none">
<img onerror="this.style.display=&#39;none&#39;" src="https://incisive-wrapper.kreatio.com/images/loading.gif?article_id=7b811d38-4f99-cf08-417b-8eb935aed270&amp;page_type=article_page" alt="Loading" />
</div>
</body>
</html>
