<!DOCTYPE html>
<html class="no-svg no-js" itemscope itemtype="http://schema.org/WebPage" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta http-equiv="Content-Type" content="text/html;charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"30b3ffac80","applicationID":"29725091","transactionName":"dAwPFRELDlhUFBpDQkRMEQAEAREbQg5aQ21WERUIAAgH","queueTime":0,"applicationTime":2671,"agent":""}</script>
<script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="format-detection" content="telephone=no" />
<meta name="HandheldFriendly" content="True" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<meta name="google-site-verification" content="tGci50LRnB4lh1psBDfiQOWlat0mJE3zFqgK11txjNE" />
<meta name="msvalidate.01" content="EBEF18626E74108AF52FD6A90AA49369" />
<title>GitLab urges users to upgrade after disclosing 13 security flaws</title>
<meta name="description" content="GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities " />
<meta name="keywords" content="CVE-2019-12430, CVE-2019-12432, CVE-2019-12431, CVE-2019-12434, GitLab 11.9.12, GitLab 11.10.5, GitLab 11.11.1" />

<meta name="DCSext.topics" content="cve-2019-12430;cve-2019-12432;cve-2019-12431;cve-2019-12434;gitlab-11-9-12;gitlab-11-10-5;gitlab-11-11-1;gitlab" />

<link rel="canonical" href="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade" />
<link rel="syndication-source" href="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade" />
<link rel="original-source" href="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade" />
<meta property="article:modified_time" content="2019-06-05T15:16:23+01:00" />
<meta property="article:published_time" content="2019-06-05T15:16:00+01:00" />
<meta name="news_keywords" content="Security ,CVE-2019-12430,CVE-2019-12432,CVE-2019-12431,CVE-2019-12434,GitLab 11.9.12,GitLab 11.10.5,GitLab 11.11.1,Gitlab" />
<meta http-equiv="Set-Cookie" content="last_page_viewed=https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade;path=/;expires=2019-06-05 21:19:02 +0100;domain=.computing.co.uk;" />
<meta http-equiv="Set-Cookie" content="last_visited_page=/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade;path=/;expires=2019-06-05 21:19:02 +0100;domain=.computing.co.uk;">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="57x57">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-76x76.png" rel="apple-touch-icon" sizes="76x76">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180">
<link href="https://www.computing.co.uk/images/favicons/icon-hires.png?0456789" rel="icon" sizes="192x192">
<link href="https://www.computing.co.uk/images/favicons/icon-normal.png?0456785" rel="icon" sizes="128x128">
<link href="https://www.computing.co.uk/images/favicons/32x32.ico" rel="shortcut icon" type="image/png">
<meta name="msapplication-TileImage" content="https://www.computing.co.uk/images/favicons/mstile-144x144.png?100518">
<meta name="msapplication-TileColor" content="#094c81">
<meta property="og:title" content="GitLab urges users to upgrade after disclosing 13 security flaws | Computing " />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade" />
<meta property="og:image" content="http://www.computing.co.uk/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-370x229.jpg" />
<meta property="og:site_name" content="http://www.computing.co.uk" />
<meta property="og:description" content="GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities,Security ,CVE-2019-12430,CVE-2019-12432,CVE-2019-12431,CVE-2019-12434,GitLab 11.9.12,GitLab 11.10.5,GitLab 11.11.1,Gitlab" " />
<meta name="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="computing_news" />
<meta name="twitter:domain" content="//www.computing.co.uk/">
<meta property="twitter:url" content="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade" />
<meta property="twitter:image" content="http://www.computing.co.uk/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-370x229.jpg" />
<meta property="twitter:description" content="GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities" />
<meta itemprop="name" content="GitLab urges users to upgrade after disclosing 13 security flaws | Computing" />
<meta itemprop="description" content="GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities,Security ,CVE-2019-12430,CVE-2019-12432,CVE-2019-12431,CVE-2019-12434,GitLab 11.9.12,GitLab 11.10.5,GitLab 11.11.1,Gitlab" />
<meta itemprop="image" content="http://www.computing.co.uk/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-370x229.jpg" />
<link href="//assets.computing.co.uk/cdn/ctg/styles/styles.css" media="all" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
		<script src="http://assets.computing.co.uk/cdn/global/scripts/html5shiv.js"></script>
		<link href="http://assets.computing.co.uk/respond-proxy.html" id="respond-proxy" rel="respond-proxy" />
		<link href="/images/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" />
		<![endif]-->
<!--[if lt IE 9]>
        	<script src="http://assets.computing.co.uk/cdn/global/scripts/respond.js"></script>
           	<script src="/javascripts/respond.proxy.js"></script>
		<![endif]-->


<script type="text/javascript" language="Javascript">
universal_variable_string = '{ "content": { "article":"news", "source":"Computing", "author":"Dev Kundaliya", "medium":"text", "published":"2019-06-05T15:16:00+01:00", "tag":["cve-2019-12430","cve-2019-12432","cve-2019-12431","cve-2019-12434","gitlab-11-9-12","gitlab-11-10-5","gitlab-11-11-1","gitlab"], "image":"/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-185x114.jpg", "restriction":"default","barrier":"free"}, "page": { "url": "https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade", "title": "GitLab urges users to upgrade after disclosing 13 security flaws", "description": "GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities ", "type": "article", "category": "security", "parentcategory": "security", "id": "3076854", "environment": "live", "site":"computing.co.uk", "platform":"desktop"} }';
</script>

<script type="text/javascript" src='//assets.computing.co.uk/javascript/live/computing/javascript-computing.head.min.js'></script>

<script>
		(function(H){H.className=H.className.replace(/\bno-js\b/,'')})(document.documentElement);
		(function(H){H.className=H.className.replace(/\bno-svg\b/,'')})(document.documentElement);
		 !function(){"use strict";function e(e,t,s){e.addEventListener?e.addEventListener(t,s,!1):e.attachEvent&&e.attachEvent("on"+t,s)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function s(){if(window.localStorage&&window.XMLHttpRequest)if(t(n))c(localStorage.font_css_cache);else{var e=new XMLHttpRequest;e.open("GET",n,!0),e.onreadystatechange=function(){4===e.readyState&&200===e.status&&(c(e.responseText),localStorage.font_css_cache=e.responseText,localStorage.font_css_cache_file=n)},e.send()}else{var s=document.createElement("link");s.href=n,s.rel="stylesheet",s.type="text/css",document.getElementsByTagName("head")[0].appendChild(s),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.setAttribute("type","text/css"),document.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var n="//assets.computing.co.uk/cdn/iw/styles/fonts/sourcesans_sourcesansbold.css?ver=1";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?s():e(window,"load",s)}();
		</script>
<script src="//code.jquery.com/jquery-1.11.2.min.js"></script>
</head>
<body class="article ctg  ">
<div id="rdm-overlay" class="ad-slot-overlay"></div>
<div id="rdm-wallpaper" class="ad-slot-wallpaper"></div>
<div class="container">
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="menu-sidebar">
<div class="menu-sidebar-inner">
<div class="search-3 header-search-holder blur">
<form id="search_form" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>
</div>
<nav class="mobile-nav">
<ul class="mobile-nav-ul">
<li class="active">
<div class="mobile-menu-title">
<a title="Home" href="/">Home</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="News" href="/type/news">News</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Big Data &amp; Analytics" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="DevOps" href="/category/devops">DevOps</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Security" href="/category/security">Security</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="GDPR" href="/tag/gdpr ">GDPR</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="AI &amp; ML" href="/tag/artificial-intelligence">AI &amp; ML</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Women in IT Excellence" href="/tag/women-in-it-excellence-awards">Women in IT Excellence</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Cloud &amp; Infrastructure" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="CIO" href="/tag/cio">CIO</a>
</div>
</li>
</ul>
</nav>
<div class="menu-sidebar-inner">
<ul class="sidebar-list">
<li>
<a href="/events" target="_blank">Events</a>
</li>
<li>
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
</li>

<li>
<a href="https://www.computing.co.uk/static/spotlights">
Spotlights</a>
</li>
<li>
<a href="https://www.computing.co.uk/series/profile/delta-top-250-uk-it-leaders">IT Leaders 250</a>
</li>
<li>
<a href="//www.computing.co.uk/static/research">Research</a>
</li>
<li>
<a href="https://www.computingdelta.com">Delta</a>
</li>
<li class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</li>
<li class="nav-tools login-icon menu-login-trigger"><a href="">Sign in</a></li>
</ul>
</div>
</div>
<nav class="main-top-nav">
<ul class="main-top-content main-top-menu content-width">
<li class="main-top-title main-top-tab-panel main-top-events" id="events">
<a href="/events" target="_blank">Events</a>
<ul class="menu-top-panel">
<li>

<div class="section group content">
<div class="col-lrg span-lrg_4_of_5 latest-events">
<header>
<div class="menu-top-panel-heading">
Upcoming events
</div>
</header>
<div class="latest-events-holder" id="featured-event">
<article>
<div class="image-text-group-a">
<a target="_blank" href="http://events.computing.co.uk/techmarketingforum"><img alt="event logo" title="Technology Marketing &amp; Innovation Forum" src="https://www.incisive-events.com/IMG/887/63887/tmif-logo-cymk-130x80.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a href="http://events.computing.co.uk/techmarketingforum" title="Technology Marketing &amp; Innovation Forum" target="_blank">Technology Marketing &amp; Innovation Forum</a>
</h5>
<p class="truncate-listing">
Forum for Tech marketing professionals
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="14-06-2019">
<strong>Date:</strong> 14 Jun 2019
</time>
</li>
<li>
Jumeriah Carlton Tower, London
</li>
</ul>
</div>
</article>
<article>
<div class="image-text-group-a">
<a target="_blank" href="http://events.computing.co.uk/techmarketingawards"><img alt="event logo" title="Tech Marketing &amp; Innovation Awards 2019" src="https://www.incisive-events.com/IMG/225/66225/ctgtmia19-logo-01-01-130x80.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a href="http://events.computing.co.uk/techmarketingawards" title="Tech Marketing &amp; Innovation Awards 2019" target="_blank">Tech Marketing &amp; Innovation Awards 2019</a>
</h5>
<p class="truncate-listing">
Celebrating the exceptional work produced by B2B Tech marketers, teams and agencies.
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="14-06-2019">
<strong>Date:</strong> 14 Jun 2019
</time>
</li>
<li>
Jumeirah Carlton Tower, London
</li>
</ul>
</div>
</article>
</div>
<div class="latest-events-holder">
<article>
<div class="image-text-group-a">
<a target="_blank" href="http://webinars.computing.co.uk/Why-integrated-Cloud-ERP-is-the-whetstone-your-competitive-edge-needs/register?redirect=%2FWhy-integrated-Cloud-ERP-is-the-whetstone-your-competitive-edge-needs"><img alt="event logo" title="Why integrated Cloud ERP is the whetstone your competitive edge needs" src="https://www.incisive-events.com/IMG/629/58629/computing-webinar-logo-130x80.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a href="http://webinars.computing.co.uk/Why-integrated-Cloud-ERP-is-the-whetstone-your-competitive-edge-needs/register?redirect=%2FWhy-integrated-Cloud-ERP-is-the-whetstone-your-competitive-edge-needs" title="Why integrated Cloud ERP is the whetstone your competitive edge needs" target="_blank">Why integrated Cloud ERP is the whetstone your competitive edge needs</a>
</h5>
<p class="truncate-listing">
An integrated, cloud-based financials or HCM platform can foster a business and workplace environment where business insights happen in real-time, agility is the norm, and global resources can be managed more easily. But what compels businesses to tear themselves away from on-prem products? Is it agility? Cost? User-experience? Scalability? Business insights?
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="20-06-2019">
<strong>Date:</strong> 20 Jun 2019
</time>
</li>
<li>
Your Computer
</li>
</ul>
</div>
</article>
<article>
<div class="image-text-group-a">
<a target="_blank" href="http://events.computing.co.uk/digitalleadersawards"><img alt="event logo" title="Digital Technology Leaders Awards 2019" src="https://www.incisive-events.com/IMG/136/66136/dtl-awards-2019-130x80.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title">
<a href="http://events.computing.co.uk/digitalleadersawards" title="Digital Technology Leaders Awards 2019" target="_blank">Digital Technology Leaders Awards 2019</a>
</h5>
<p class="truncate-listing">
The Computing Digital Technology Leaders Awards exist to recognise the achievements of the individuals and companies who are really making it happen at the coal face of the digital technology stack: from website design and coding to UX and scrum masters all the way up to the CDO.
</p>
<ul class="article-meta-details">
<li>
<time itemprop="datePublished" datetime="02-07-2019">
<strong>Date:</strong> 02 Jul 2019
</time>
</li>
<li>
London
</li>
</ul>
</div>
</article>
</div>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="/events" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all events
</a>
</div>
</div>
</div>
</div>

</li>
</ul>
</li>
<li class="main-top-title main-top-tab-panel main-top-hound" id="hound">
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
<ul class="menu-top-panel">
<li>

<div class="section group content">
<div class="col span-lrg_4_of_5">
<header>
<div class="menu-top-panel-heading">LATEST WHITEPAPERS</div>
</header>
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/4bc47282-68f3-4dbf-beb1-d250cbdafe80/4/fill/Darktrace-120x194.jpg" alt="Darktrace 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Cyber AI Response: Threat Report 2019</a>
<p>This white paper details 7 case studies of attacks that were intercepted and neutralised by Darktrace cyber defense AI, including a zero-day trojan in a manufacturing company's network. Learn how Darktrace Antigena AI Response modules fight back autonomously, no matter where a threat may emerge, extending to the Cloud, Email and SaaS.</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?lid=5115&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/6b3b22c4-9df7-4b8d-a268-d4a1bc07e8b1/4/fill/Darktrace-120x194.jpg" alt="Darktrace 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Cyber AI &amp; Darktrace Cloud</a>
<p>This white paper explores how cloud is a security blind spot for many organisations who struggle with the limited visibility and control in this new environment, where their existing security tools are often not applicable.</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?lid=4907&amp;pid=300000&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
</div>
<div class="col span-lrg_1_of_5">
<section class="hound-search">
<header>
<div class="menu-top-panel-heading">Find whitepapers</div>
<div class="menu-top-panel-subheading">Search by title or subject area</div>
</header>
<aside>
<form target="_blank" name="multi" method="get" id="hound-search" enctype="multipart/form-data" action="//www.computing.co.uk/static/resources-search-results">
<input type="search" id="search-hound" placeholder="Search papers here" tabindex="1" required="" name="wpSearch">
<input type="hidden" value="computing" name="publisher">
<input type="submit" class="btn search-hound">
</form>
</aside>
</section>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="https://www.computing.co.uk/static/resources" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all whitepapers
</a>
</div>
</div>
</div>
</div>

</li>
</ul>
</li>
<li class="main-top-title main-top-tab-panel main-top-spotlight" id="spotlight">
<a href="https://www.computing.co.uk/static/spotlights" target="_blank">
Spotlights
</a>
<ul class="menu-top-panel">
<li>
<div class="section group content">
<div class="col span-lrg_3_of_3">
<header>
<div class="menu-top-panel-heading">Spotlights</div>
</header>
<section class="top-spotlight">
<div class="image-text-group-b">
<strong>
</strong>
<p>Welcome to Computing's Spotlight section, where we focus in on particularly important themes and topics of enterprise IT.</p>
</div>
</section>
<section class="top-spotlight">
<div class="image-text-group-b">
<strong>
</strong>
<div class="image-text-group-a">
<p><img border="0" alt="" src="/w-images/68428764-f3fe-4084-adfb-ea9bb372b955/3/fill/Liaisonlogoresize400-400x220.png" width="200" height="110" /></p>
</div>
<div class="image-text-group-b">
<h3><a href="https://www.computing.co.uk/ctg/content-hub/3030021/data-strategy-spotlight">Data Strategy Spotlight</a></h3>
<p>Computing, in association with Liaison Technologies, is hosting the Data Strategy channel.</p>
</div>
</div>
</section>
</div>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-tab-link main-top-fundcentre" id="">
<a href="https://www.computing.co.uk/series/profile/delta-top-250-uk-it-leaders">IT Leaders 250</a>
</li>
<li class="main-top-title main-top-tab-link main-top-advertise" id="">
<a href="//www.computing.co.uk/static/research">Research</a>
</li>
<li class="main-top-title main-top-tab-link main-top-advertise" id="advertise">
<a href="https://www.computingdelta.com" target="_blank">Delta</a>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-login" id="login" style="display:none;">
<a href="/userlogin">Sign in</a>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-user" id="user" style="display: none;">
<a href="/home/manage_account" class="user-info"></a>
<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a href="https://www.computing.co.uk/userlogin" title="Sign in">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a href="https://www.computing.co.uk/userlogin" title="Sign in" class="sign-in-user-link">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>
<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu">
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>

<li><a class="account-user-link" title="Account details" href="https://www.computing.co.uk/home/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="https://www.computing.co.uk/home/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="https://www.computing.co.uk/home/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-sociallinks" id="follow" style="display:none;">
<a href="#">Follow us</a>
<ul class="header-tools-content">
<li>
<div class="nav-tools rss-icon">
<a href="//www.computing.co.uk/rss-feeds" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="https://www.linkedin.com/showcase/computing--/" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="https://www.facebook.com/ComputingUK" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="https://www.youtube.com/channel/UCpELdRcHhBVtUdGy1QhgF2Q/featured" target="_blank">YouTube</a>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-link main-top-register" id="register" style="display:none;">
<a href="//www.computing.co.uk/static/register" target="_blank">Register</a>
</li>
<li class="main-top-title main-top-align-right main-top-user-status" id="rdm_header_user_status_link"></li>
</ul>
</nav>
<header role="banner" class="main-head">
<div class="main-head-content content-width">
<div class="site-header">
<div class="site-logo-holder" itemscope itemtype="http://schema.org/Organization">
<div itemprop="name" class="screen-reader-text">
Computing
</div>
<a href="/" title="Return to homepage" class="site-logo"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="Computing" class="sprite investmentweek-logo"></a>
</div>
<div class="search-1 header-search-holder blur">
<form id="search_form_bottom" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>

</div>
</div>
</header>
<nav class="nav">
<div class="holder">
<div class="hamburger-style" id="nav-toggle" aria-label="Menu">
<span></span>
</div>
<div class="clicker4" aria-label="Login"></div>
<script type="text/conditional-html" id="tablet-conditional-navigation">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</script>
<div id="conditional-navigation" class="">

<nav class="primary-nav nav-colour01" role="navigation" aria-label="Primary">
<ul class="main-menu main-top-content content-width">
<li class="menu-title">
<a title="Home" href="/">Home</a>
</li>
<li class="menu-title">
<a title="News" href="/type/news">News</a>
</li>
<li class="menu-title">
<a title="Big Data &amp; Analytics" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
</li>
<li class="menu-title">
<a title="DevOps" href="/category/devops">DevOps</a>
</li>
<li class="menu-title">
<a title="Security" href="/category/security">Security</a>
</li>
<li class="menu-title">
<a title="GDPR" href="/tag/gdpr ">GDPR</a>
</li>
<li class="menu-title">
<a title="AI &amp; ML" href="/tag/artificial-intelligence">AI &amp; ML</a>
</li>
<li class="menu-title">
<a title="Women in IT Excellence" href="/tag/women-in-it-excellence-awards">Women in IT Excellence</a>
</li>
<li class="menu-title">
<a title="Cloud &amp; Infrastructure" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
</li>
<li class="menu-title">
<a title="CIO" href="/tag/cio">CIO</a>
</li>
</ul>
</nav>
</div>
<div class="mobile-branding"><a href="/" class="mobile-branding-link" alt="Computing"></a></div>
</div>
<div class="mask">
<div class="menu4">
<div>
<a href="/home/manage_account" class="user-info"></a>
<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a href="https://www.computing.co.uk/userlogin" title="Sign in">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a href="https://www.computing.co.uk/userlogin" title="Sign in" class="sign-in-user-link">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>
<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu">
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>

<li><a class="account-user-link" title="Account details" href="https://www.computing.co.uk/home/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="https://www.computing.co.uk/home/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="https://www.computing.co.uk/home/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>
</div>
</div>
</div>
</nav>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-below-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="page-content ajax_search">
<header class="article-header">
<div class="content">
<div class="content-inner">
<div class="main-content">
<div class="section group">
<div class="col span_1_of_5">
<img class="print-branding" src="//assets.computing.co.uk/cdn/ctg/images/site-logo.png" alt="Computing">
<nav>
<ul class="meta-taxonomy-list breadcrumb">
<li>
<a href="/category/security/">Security</a>
</li>
</ul>
</nav>
</div>
<div class="col span_4_of_5">
<h1 itemprop="name" class="article-title">GitLab urges users to upgrade after disclosing 13 security flaws</h1>
<h2 class="article-sub-title">GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities </h2>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="content">
 <main role="main" class="content-inner">
<div class="main-content">
<article class="section group article">
<div class="col span_1_of_5"></div>
<div class="col span_4_of_5 article-col">
<figure class="main">
<img alt="GitLab urges users to upgrade after disclosing 13 security flaws" title="GitLab urges users to upgrade after disclosing 13 security flaws" src="/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-580x358.jpg" />
<figcaption>
<div class="caption-text">
GitLab has released three new versions, namely 11.9.12, 11.10.5, and 11.11.1, for GitLab Enterprise Edition and Community Edition
</div>
</figcaption>
</figure>
<div class="article-meta-container group">
<ul class="meta-taxonomy-list author-dateline">
<li class="author-dateline-name">
Dev Kundaliya
</li>
<li class="author-dateline-time">
<time datetime="2019-06-05" itemprop="datePublished">
05 June 2019
</time>
</li>
</ul>
<div class="tools-meta-outer">
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=GitLab+urges+users+to+upgrade+after+disclosing+13+security+flaws&amp;url=https://www.computing.co.uk/3076854/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/3076854" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
<span class="screen-reader-text">LinkedIn</span>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/3076854&amp;title=GitLab+urges+users+to+upgrade+after+disclosing+13+security+flaws" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="mailto:?subject=GitLab urges users to upgrade after disclosing 13 security flaws&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F3076854">&nbsp;</a>
</div>
</li>
</ul>

<div class="article-meta-numbers">
<div class="comment-count">
<a href="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade#disqus_thread">0 Comments</a>
</div>
<div class="social-count">
<a href="https://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade"><span class="share-total"></span></a>
</div>
</div>
</div>
</div>
<div id="rdm-below-summary"></div>
<div class="article-page-body-content">

<p>GitLab has released three new versions,&nbsp;namely 11.9.12, 11.10.5, and 11.11.1, for GitLab Enterprise Edition (EE) and Community Edition (CE), to fix&nbsp;13 security flaws. <a href="https://about.gitlab.com/2019/06/03/security-release-gitlab-11-dot-11-dot-1-released/">GitLab has advised users to upgrade</a>&nbsp;as soon as possible.</p>
<p>The details about those vulnerabilities will be revealed in an issue tracker in about 30 days, according to GitLab.</p>
<div id="rdm-above-related"></div>
<p>The first flaw in the list, assigned CVE-2019-12430, is a remote command execution flaw existing in GitLab's repository download feature. It affects GitLab CE/EE version 11.11 and could allow a malicious user to run commands remotely using the repository download feature.</p>
<hr />
<p><img border="0" src="/w-images/3b171a7f-f047-4eb3-903a-7e76323937f2/2/ComputingCloudExcellenceAwards2019May20199898-98x98.jpg" width="98" height="98" alt="Computing Cloud Excellence Awards 2019 logo" title="Computing Cloud Excellence Awards 2019 logo" class="left" /></p>
<p><em>Computing's <strong>Cloud Excellence Awards</strong> return on the 19th September 2019, recognising the very best of cloud computing in the UK across end users, suppliers and products. Who is the Cloud Architect of the Year? What is the Best Cloud Development Platform? And who is the Cloud Entrepreneur of the Year. <a title="Computing Cloud Excellence Awards 2019 - 19th September 2019" href="https://events.computing.co.uk/cloudexcellence" target="_blank" rel="noopener noreferrer"><strong>Entry is FREE</strong> - the deadline is Friday 28th June</a>.&nbsp;</em></p>
<hr />
<p>The second vulnerability, affecting GitLab CE/EE 8.13 and later, is indexed as CVE-2019-12432. GitLab says this vulnerability could allow non-member users subscribed to issue notifications to access the title of confidential issues through the unsubscription page.</p>
<p>The third flaw, assigned CVE-2019-12431, was found to impact GitLab CE/EE 8.13 and later and could enable restricted users to access the metadata of private milestones through the search API.</p>
<p>The next vulnerability, named CVE-2019-12434, affects GitLab CE/EE 10.6 and later. It could enable attackers to predict the URL slug of private projects.</p>
<p>The fifth vulnerability could disclose metadata of confidential issues (such as labels and status) to restricted users. This flaw impacts CE/EE 11.9 and later and is assigned CVE-2019-12429.</p>
<p>Next up in the list is a vulnerability that allows users to circumvent the compulsory external authentication provider sign-in restrictions. The issue affects CE/EE 6.8 and later and is assigned CVE-2019-12428.</p>
<p>Another flaw, indexed as CVE-2019-12433, affects CE/EE 11.7 and later. It could lead to multiple permission issues by allowing creation of internal projects in private groups.</p>
<p><strong>Other vulnerabilities fixed in GitLab's latest versions are:</strong></p>
<ul>
<li>Server-Side Request Forgery Through DNS Rebinding (CVE-2019-12443)</li>
<li>Stored Cross-Site Scripting on Wiki Pages (CVE-2019-12444)</li>
<li>Stored Cross-Site Scripting on Notes (CVE-2019-12445)</li>
<li>Repository Password Disclosed on Import Error Page (CVE-2019-12446)</li>
<li>Protected Branches Restriction Rules Bypass (CVE-2019-12441)</li>
<li>Stored Cross-Site Scripting Vulnerability on Child Epics (CVE-2019-12442)</li>
</ul>
<p>GitLab said that it has also upgraded Knative to version 0.5 for the GitLab 11.11, 11.10 and 11.9 packages. The new release contains several security fixes.</p>
<p><img border="0" src="/w-images/f5c0f5a2-2f2c-4ea6-bbc5-1148efada24f/3/ComputingCRNWomeninTechFestival2019March201925050-250x50.jpg" width="250" height="50" alt="Logo for the Computing and CRN Women in Tech Festival 2019" title="Logo for the Computing and CRN Women in Tech Festival 2019" class="left" /></p>
<p><em>Computing and CRN have united to present the <strong>Women in Tech Festival UK 2019</strong>, on 17 September in London. </em></p>
<p><em>The event will celebrate successful women in the IT industry, enabling attendes to hear about, and to share, personal experiences of professional journeys and challenges. </em></p>
<p><em>Whether you're the &lsquo;Next Generation', an &lsquo;Inspirational Leader', or an &lsquo;Innovator of Tech' this event will offer inspiration on not only how to improve yourself, but how to help others too.&nbsp; <a title="Women in Tech Festival UK" href="http://www.womenintechfestivaluk.com" target="_blank" rel="noopener noreferrer">The event is <strong>FREE</strong> for qualifying IT pros, but places will go fast</a></em> <img /></p>
<div id="rdm-below-article-text"></div>

<section class="further-reading">
<header>
<h4 itemprop="name">Further reading</h4>
</header>
<div class="section group">
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<div class="listings-article-title"><a title="TruffleHog tool will sniff out secret keys on Github" href="/ctg/news/3002172/trufflehog-tool-will-sniff-out-secret-keys-on-github">TruffleHog tool will sniff out secret keys on Github</a></div>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/devops/">DevOps</a>
</li>
<li>
<time datetime="2017-01-09" itemprop="datePublished">
09 Jan 2017
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<div class="listings-article-title"><a title="Red faces at Gitlab as sysadmin expunges 300GB of data" href="/ctg/news/3003799/gitlab-sysadmin-accidentally-deletes-300gb-of-data">Red faces at Gitlab as sysadmin expunges 300GB of data</a></div>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/software/">Software</a>
</li>
<li>
<time datetime="2017-02-01" itemprop="datePublished">
01 Feb 2017
</time>
</li>
</ul>
</div>
</article>
</div>
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<div class="listings-article-title"><a title="GitHub, Bitbucket and GitLab open-source projects hacked and held for ransom" href="/ctg/news/3075150/github-bitbucket-gitlab-open-source-hack-ransom">GitHub, Bitbucket and GitLab open-source projects hacked and held for ransom</a></div>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/software/">Software</a>
</li>
<li>
<time datetime="2019-05-07" itemprop="datePublished">
07 May 2019
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<div class="listings-article-title"><a title="Confirmed: Microsoft buys GitHub in $7.5bn deal" href="/ctg/news/3033473/confirmed-microsoft-buys-github-in-usd75bn-deal">Confirmed: Microsoft buys GitHub in $7.5bn deal</a></div>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/software/">Software</a>
</li>
<li>
<time datetime="2018-06-04" itemprop="datePublished">
04 Jun 2018
</time>
</li>
</ul>
</div>
</article>
</div>
</div>
</section>

<div id="rdm-below-article-body"></div>
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=GitLab+urges+users+to+upgrade+after+disclosing+13+security+flaws&amp;url=https://www.computing.co.uk/3076854/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/3076854" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
<span class="screen-reader-text">LinkedIn</span>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/3076854&amp;title=GitLab+urges+users+to+upgrade+after+disclosing+13+security+flaws" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="mailto:?subject=GitLab urges users to upgrade after disclosing 13 security flaws&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F3076854">&nbsp;</a>
</div>
</li>
</ul>

<ul class="meta-taxonomy-list related-links">
<li>
Topics
</li>
<li>
<a href="/category/security/">Security</a>
</li>
<li>
<a href="/tag/cve-2019-12430/">CVE-2019-12430</a>
</li>
<li>
<a href="/tag/cve-2019-12432/">CVE-2019-12432</a>
</li>
<li>
<a href="/tag/cve-2019-12431/">CVE-2019-12431</a>
</li>
<li>
<a href="/tag/cve-2019-12434/">CVE-2019-12434</a>
</li>
<li>
<a href="/tag/gitlab-11-9-12/">GitLab 11.9.12</a>
</li>
<li>
<a href="/tag/gitlab-11-10-5/">GitLab 11.10.5</a>
</li>
<li>
<a href="/tag/gitlab-11-11-1/">GitLab 11.11.1</a>
</li>
<li>
<a href="/tag/gitlab/">Gitlab</a>
</li>
</ul>


</div>
</div>
</article>

<div id="rdm-above-series-blog"></div>
<div id="rdm-above-related"></div>

<div id="rdm-above-more-news"></div>
<section class="news-articles">
<header class="related-listings-header">
<h4 itemprop="name">More news</h4>
</header>
<div class="section group">
<article class="col span_2_of_4 first-element">
<div class="image-text-group-a">
<a href="/ctg/news/3076892/managing-endpoint-devices-computing-technology-forum"><img title="Managing endpoint devices: As big a challenge today as it’s ever been" alt="Managing endpoint devices: As big a challenge today as it’s ever been" src="/w-images/6f9ca378-b70e-451f-81a1-a47988ba03c7/0/multipledevices1-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Managing endpoint devices: As big a challenge today as it&#39;s ever been?" href="/ctg/news/3076892/managing-endpoint-devices-computing-technology-forum">Managing endpoint devices: As big a challenge today as it&#39;s ever been?</a></h5>
<p class="section-story">
Client management has always been a tough job, but will adding IoT devices to the mix make it even more complicated?
</p>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/hardware/">Hardware</a>
</li>
<li>
<time datetime="2019-06-05" itemprop="datePublished">
05 June 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade"><img title="GitLab urges users to upgrade after disclosing 13 security flaws" alt="GitLab urges users to upgrade after disclosing 13 security flaws" src="/w-images/7d42dca9-b952-4a6d-b353-2478154f47df/3/GitLab-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="GitLab urges users to upgrade after disclosing 13 security flaws" href="/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade">GitLab urges users to upgrade after disclosing 13 security flaws</a></h5>
<p class="section-story">
GitLab advises users to upgrade immediately after admitting to a series of vulnerabilities
</p>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/security/">Security</a>
</li>
<li>
<time datetime="2019-06-05" itemprop="datePublished">
05 June 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076877/oracle-and-microsoft-unveil-cloud-interoperability-partnership"><img title="Oracle and Microsoft unveil cloud interoperability partnership" alt="Oracle and Microsoft unveil cloud interoperability partnership" src="/w-images/e0755463-b979-44a1-9e43-bbf9bb5c37cb/3/fill/azureoracle-230x142.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Oracle and Microsoft unveil cloud interoperability partnership" href="/ctg/news/3076877/oracle-and-microsoft-unveil-cloud-interoperability-partnership">Oracle and Microsoft unveil cloud interoperability partnership</a></h5>
<p class="section-story">
Services run in Azure will now be able to connect seamlessly with Oracle&#39;s databases in the cloud
</p>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/cloud-and-infrastructure/">Cloud and Infrastructure</a>
</li>
<li>
<time datetime="2019-06-05" itemprop="datePublished">
05 June 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076860/time-to-break-up-social-media-firms-mps-and-activists-on-the-threat-to-democracy-of-online-disinformation"><img title="the convention" alt="the convention" src="/w-images/0fa2999b-e90f-4340-a570-7d7c8a4de510/2/theconvention-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Time to break up social media firms? MPs and activists on the threat to democracy from online disinformation" href="/ctg/news/3076860/time-to-break-up-social-media-firms-mps-and-activists-on-the-threat-to-democracy-of-online-disinformation">Time to break up social media firms? MPs and activists on the threat to democracy from online disinformation</a></h5>
<p class="section-story">
Western democracy is under severe threat from autocratic regimes&#39; use of Facebook and Twitter
</p>
<ul class="article-meta-details">
<li>
<a class="ctg-link" href="/category/security/">Security</a>
</li>
<li>
<time datetime="2019-06-05" itemprop="datePublished">
05 June 2019
</time>
</li>
</ul>
</div>
</article>
</div>
</section>


<div id="rdm-above-comments"></div>
<div id="disqus_thread"></div>
<script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.computing.co.uk/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//computing-live.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div class="scrollup">
Back to Top
</div>
</div>
<div role="complementary" class="sidebar">
<div id="rdm-rhc-top" class="ad-slot"></div>

<section class="popular-articles">
<header class="related-listings-header">
<h4 itemprop="name">Most read</h4>
</header>
<div class="section group">
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076782/william-hill-security-ciso-board"><img title="William Hill Group CISO Killian Faughnan presenting at Infosec 2019" alt="William Hill Group CISO Killian Faughnan presenting at Infosec 2019" src="/w-images/0ab39978-87ee-4807-891b-4d0bd7e03380/2/WilliamHillGroupCISOKillianFaughnanInfosec2019June2019590360-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="How William Hill&#39;s CISO sells cyber security to the board: Simple, practical, pragmatic and obvious" href="/ctg/news/3076782/william-hill-security-ciso-board">How William Hill&#39;s CISO sells cyber security to the board: Simple, practical, pragmatic and obvious</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076754/sap-and-oracle-are-all-about-locking-people-in-claims-rimini-street-ceo"><img title="SAP and Oracle are &#39;all about locking people in&#39;, claims Rimini Street CEO" alt="SAP and Oracle are &#39;all about locking people in&#39;, claims Rimini Street CEO" src="/w-images/77f68d0f-5781-4d82-b199-a03e7e2951f3/3/fill/SethRavinRiminiStreet-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="SAP and Oracle are &#39;all about locking people in&#39;, claims Rimini Street CEO" href="/ctg/news/3076754/sap-and-oracle-are-all-about-locking-people-in-claims-rimini-street-ceo">SAP and Oracle are &#39;all about locking people in&#39;, claims Rimini Street CEO</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076796/security-training-culture-home-hsbc-paula-kershaw"><img title="Good cyber security culture should, literally, begin in employees’ homes, says HSBC CISO Paula Kershaw" alt="Good cyber security culture should, literally, begin in employees’ homes, says HSBC CISO Paula Kershaw" src="/w-images/406f1206-df2b-4795-b593-f7210b368554/0/schoolsign-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Good cyber security culture should, literally, begin in employees&#39; homes, says HSBC CISO Paula Kershaw" href="/ctg/news/3076796/security-training-culture-home-hsbc-paula-kershaw">Good cyber security culture should, literally, begin in employees&#39; homes, says HSBC CISO Paula Kershaw</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076805/it-ot-ugly-baby-anglo-american-ciso"><img title="&#39;IT shouldn’t tell OT they have an ugly baby,&#39; says Anglo American CISO" alt="&#39;IT shouldn’t tell OT they have an ugly baby,&#39; says Anglo American CISO" src="/w-images/0b35fe42-43dd-4bdd-a22c-b66c9f1c3ae0/2/Uglymonster-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="&#39;IT shouldn&#39;t tell OT they have an ugly baby,&#39; says Anglo American CISO" href="/ctg/news/3076805/it-ot-ugly-baby-anglo-american-ciso">&#39;IT shouldn&#39;t tell OT they have an ugly baby,&#39; says Anglo American CISO</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/ctg/news/3076819/adware-security-android-bricked-research"><img title="Android adware plugin crippled smartphones, say researchers" alt="Android adware plugin crippled smartphones, say researchers" src="/w-images/e67f1a19-93d7-4b4d-9e6d-8b2763a3b301/3/Brick-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Android adware plugin crippled smartphones, say researchers" href="/ctg/news/3076819/adware-security-android-bricked-research">Android adware plugin crippled smartphones, say researchers</a>
</h5>
</div>
</article>
</div>
</section>

<div id="rdm-rhc-whitepapers" class="ad-slot"></div>
<div id="rdm-rhc-bottom" class="ad-slot"></div>
</div>
</main>
</div>
</div>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-footer" class="ad-slot-full"></div>
</div>
</div>
</aside>
<footer class="main-footer">
<div class="main-footer-content main-footer-links">
<div class="main-footer-content-inner content-width">
<ul class="main-footer-nav">
<li class="menu-title"><a title="Contact us" href="//www.computing.co.uk/static/contacts">Contact</a></li>
<li class="menu-title"><a title="Delta" href="https://www.computingdelta.com/">Delta</a></li>
<li class="menu-title"><a title="Marketing solutions" href="http://btgmarketingsolutions.incisivemedia.com/">Marketing solutions</a></li>
<li class="menu-title"><a title="Enterprise IT Events" href="http://www.enterpriseitevents.com/">Enterprise IT Events</a></li>
<li class="menu-title"><a title="About Incisive Media" href="http://www.incisivemedia.com/our-story/" target="_blank" rel="noopener noreferrer">Incisive Media</a></li>
<li class="menu-title"><a title="Terms and conditions" href="http://www.incisivemedia.com/terms-conditions/" target="_blank" rel="noopener noreferrer">Terms &amp; conditions</a></li>
<li class="menu-title"><a title="Policies" href="https://www.incisivemedia.com/terms-conditions/#policies" target="_blank" rel="noopener noreferrer">Policies</a></li>
<li class="menu-title"><a title="Careers" href="https://www.incisivemedia.com/our-careers/?utm_source=computing&amp;utm_medium=footer_navigation&amp;utm_campaign=corporate_careers_links" target="_blank" rel="noopener noreferrer">Careers</a></li>
</ul>
<ul class="footer-tools-content main-footer-align-right">
<li>
<div class="nav-tools rss-icon">
<a href="//www.computing.co.uk/rss-feeds" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="https://www.linkedin.com/showcase/computing--/" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="https://www.facebook.com/ComputingUK" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="https://www.youtube.com/channel/UCpELdRcHhBVtUdGy1QhgF2Q/featured" target="_blank">YouTube</a>
</div>
</li>
</ul>
</div>
</div>
<div class="main-footer-content main-footer-copyright">
<div class="main-footer-content-inner content-width">
<div class="incisivemedia-footer">
<p class="corp-logo" style="float: left; padding: 20px 10px 0px 5px;"><a title="Incisive Media" href="https://www.incisivemedia.com/" target="_blank" rel="noopener noreferrer"><img src="https://assets.incisivemedia.com/production/global/images/im_logo.png" width="150" height="38" /></a></p>
<p class="copyright-full">&copy; Incisive Business Media (IP) Limited, Published by Incisive Business Media Limited, New London House, 172 Drury Lane, London WC2B 5QR, registered in England and Wales with company registration numbers 09177174 &amp; 09178013</p>
</div>
<div class="incisivemedia-accreditation">
<div class="accredit-text"><a href="http://www.incisivemedia.com/accreditations" target="_blank" rel="noopener noreferrer">Digital publisher of the year</a></div>
<div class="accreditation-logos"><span class="screen-reader-text">Digital publisher of the year 2010, 2013, 2016 &amp; 2017</span></div>
</div>
</div>
</div>
</footer>
</div>
<script src="/javascripts/cookie.js"></script>
<script type="text/javascript">
		  jQuery(document).ready(function() {
		    if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
			var userlogin_path=location.pathname;
			if(userlogin_path == "/userlogin"){
			$("span#login_error_message_header").html(getCookie("series_token_error_message").replace(/\+/g, " ")).show();
			deleteCookie("series_token_error_message");
			}}});
			 jQuery(document).ready(function() {
			$("#userlogin .btn.login").on("click",function(){
			$("span#login_error_message_header").html("").hide();
			})});
		</script>
<script type="text/javascript">
		  jQuery(document).ready(function() {
		      if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
		      if(getCookie("series_token_error_message").match("articles$") !=null){
		   $("span#login_error_message_teaser").html(getCookie("series_token_error_message").replace(/\+/g, " ").replace(/\w+$/,'')).show();
		   deleteCookie("series_token_error_message");
		   }
		   }
		   });
		    jQuery(document).ready(function() {
		   $("#login_barrier .login_submit").on("click",function(){
		   $("span#login_error_message_teaser").html("").hide();
		   });});
		</script>
<script src="//assets.computing.co.uk/cdn/ctg/scripts/scripts.js"></script>
<script src="/javascripts/KRESearch.js"></script>
<script type="text/javascript">
		    jQuery(document).ready(function() {
		    	$("#login").hover(function(){
			       $(".login-offset").hide();
				});
		    	 setTimeout(function(){ 
		    	 	jQuery("#register,#login,#follow,#free-trial").show();
					if(getCookie("logged_in") == "false"){
							jQuery("#register,#login,#follow,#free-trial").show();
						    jQuery("#user").hide();
					}else if(getCookie("logged_in") == "true"  || getCookie("logged_in") == "expired"|| getCookie("logged_in") == null){
							if(getCookie("first_name")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
								$("#user,#follow").show();
						        $("#register,#login,#free-trial").hide();
						        jQuery(".user-info").html('My account');
								if(getCookie("institutional_login") == "true"){
									if(getCookie("individual_login") == "true"){
										$(".individual").show();
										$('.institutional').hide();
										$(".user-info").html('My account');
										$("#user").removeClass("main-top-institution");
									}else{
										$(".individual").hide();
										$(".user-info").html('Welcome');
										$("#user").addClass("main-top-institution");
									}
								}else{
										$(".individual").show();
										$("#user").removeClass("main-top-institution");
								}
							}else{
									jQuery.ajax({
			                        type : 'GET',
			                        dataType : 'html',
			                        beforeSend : function(xhr) {
			                            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'))
			                        },
			                        url : '/user_info',
			                        success : function(data) {
			                            if(getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" ){
			                                if(getCookie("first_name")!= null && getCookie("subc")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
												$("#user,#follow").show();
						        				$("#register,#login,#free-trial").hide();
						        				jQuery(".user-info").html('My account');
												if(getCookie("institutional_login") == "true"){
													if(getCookie("individual_login") == "true"){
														$(".individual").show();
														$('.institutional').hide();
														$(".user-info").html('My account');
														$("#user").removeClass("main-top-institution");
													}else{
														$(".individual").hide();
														$('.institutional').show();
														$(".user-info").html('Welcome');
														$("#user").addClass("main-top-institution");
													}
												}else{
														$(".individual").show();
														$("#user").removeClass("main-top-institution");
												}
			                                }
			                            }
			                           else{
										   $("#register,#login,#follow,#free-trial").show();
									if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
										   var userlogin_path=location.pathname;
										   if(userlogin_path != "/userlogin" &&  (getCookie("series_token_error_message").match("articles$") == null)){
										   location.pathname="/userlogin";
										   }}
										}
			                        }
			                    });
							}
					}
						}, 1000);
				$("#user").hover(function(event){
				   event.preventDefault();
				   if(getCookie("institutional_login") == "true"){
						if(getCookie("individual_login") == "true"){
							$(".individual").show();
							$('.institutional').hide();
						}else{
							$(".individual").hide();
							$('.institutional').show();
						}
					}
				});
			});
		</script>
<script type="text/javascript">
		/* article teaser csrf token */
		$(function(){
			 jQuery.ajax({
            url : '/article_teaser_login',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                $( "#export_loaders" ).show();              
            },
            success : function(data) {
            	$( "#export_loaders" ).hide();
                $(".art_teaser").html(data);
            }
        });
		});
		</script>
<script type="text/javascript">
/*script for login */

    jQuery(document).on('click', '.login_form_submit.login_submit', function(event) {
    	event.preventDefault();
        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery("#userloginpop").serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                 $("#follow,#register,#login,#free-trial").hide();
                  $( "#export_loaders" ).show();
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                	$("#follow,#user").show();
                    location.reload();
                } else {
                	jQuery("#register,#login,#follow,#free-trial").show();
                	$( "#export_loaders" ).hide();
                    jQuery('#login_error_message_header,#login_error_message_teaser').show();
                    jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });

    });
    jQuery(document).on('click', '.btn.login', function(event) {
    	event.preventDefault();
        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery("#userlogin").serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                  $( "#export_loaders" ).show();
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                	var a=$(".cls_redirect").attr("value");
                	location.href=a;
                } else {
                	jQuery("#register,#login,#follow,#free-trial").show();
                	$( "#export_loaders" ).hide();
                    jQuery('#login_error_message_header,#login_error_message_teaser').show();
                    jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });

    });
    jQuery(document).on('click', '.submit_style.login_submit', function(event) {
        event.preventDefault();

        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery('#login_barrier').serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                 setTimeout(function(){ 
                  $( "#export_loaders" ).show();
                 }, 1000);
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                    location.reload()
                } else {
                   jQuery("#register,#login,#follow,#free-trial").show();
                   $( "#export_loaders" ).hide();
                   jQuery('#login_error_message_header,#login_error_message_teaser').show();
                   jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });
    });
    </script>
<script type="text/javascript">
		    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
		    var disqus_shortname = 'computing-live'; // required: replace example with your forum shortname
		 var disqus_identifier = "/ctg/news/3076854/gitlab-security-13-vulnerabilities-upgrade";
		    /* * * DON'T EDIT BELOW THIS LINE * * */
		    (function () {
		        var s = document.createElement('script'); 
		        s.async = true;
		        s.type = 'text/javascript';
		        s.src = '//computing-live.disqus.com/count.js';
		        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		    }());
	</script>

<script type="text/javascript" src='//assets.computing.co.uk/javascript/live/computing/javascript-computing.body.min.js'></script>

<script id="dsq-count-scr" src="//computing-live.disqus.com/count.js" async>
         </script> 
</body>
</html>