<!DOCTYPE html>
<html class="no-svg no-js" itemscope itemtype="http://schema.org/WebPage" lang="en" prefix="og: http://ogp.me/ns#">
	<head>
		<meta http-equiv="Content-Type" content="text/html;charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge"/>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"30b3ffac80","applicationID":"29725091","transactionName":"dAwPFRELDlhUFBpDQkRMEQAEAREbQg5aQ21WERUIAAgH","queueTime":0,"applicationTime":3628,"agent":""}</script>
<script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
<meta name="format-detection" content="telephone=no"/>
<meta name="HandheldFriendly" content="True"/>
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript"/>
<meta name="google-site-verification" content="tGci50LRnB4lh1psBDfiQOWlat0mJE3zFqgK11txjNE" />
<meta name="msvalidate.01" content="EBEF18626E74108AF52FD6A90AA49369" />

	
	<title>Samba patches flaw that let people change admin passwords | Computing</title>
    <meta name="description" content="Samba has released security updates for two vulnerabilities in the open-source " />  
	<meta name="keywords" content="Security, Denial of Service, password flaw, Patch, Samba" />


<!--Dont change the position of this file -->
<meta name="DCSext.topics" content="security;denial-of-service;password-flaw;patch;samba"/>
<!-- <link rel="canonical" href="" /> 
<link rel="syndication-source" href="" /> 
<link rel="original-source" href="" />  -->


<link rel="canonical" href="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords" />
<link rel="syndication-source" href="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords" />
<link rel="original-source" href="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords" />
<meta property="article:modified_time" content="2018-03-14T15:03:41+00:00" />
<meta property="article:published_time" content="2018-03-14T15:03:00+00:00" />
<meta name="news_keywords" content="Security ,Security,Denial of Service,password flaw,Patch,Samba"/>

<meta http-equiv="Set-Cookie" content="last_page_viewed=https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords;path=/;expires=2018-03-14 17:07:25 +0000;domain=.computing.co.uk;"/>
<meta http-equiv="Set-Cookie" content="last_visited_page=/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords;path=/;expires=2018-03-14 17:07:26 +0000;domain=.computing.co.uk;">



<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="57x57">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-76x76.png" rel="apple-touch-icon" sizes="76x76">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152">
<link href="https://www.computing.co.uk/images/favicons/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180">
<link href="https://www.computing.co.uk/images/favicons/icon-hires.png" rel="icon" sizes="192x192">
<link href="https://www.computing.co.uk/images/favicons/icon-normal.png" rel="icon" sizes="128x128">
<link href="https://www.computing.co.uk/images/favicons/32x32.ico" rel="shortcut icon" type="image/png">

<meta name="msapplication-TileImage" content="https://www.computing.co.uk/images/favicons/mstile-144x144.png">
	<meta name="msapplication-TileColor" content="#094c81">

<meta property="og:title" content="Samba patches flaw that let people change admin passwords | Computing "/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords"/>
<meta property="og:image" content="http://www.computing.co.uk/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-370x229.jpg"/>
<meta property="og:site_name" content="http://www.computing.co.uk"/>
<meta property="og:description" content="Samba has released security updates for two vulnerabilities in the open-source,Security ,Security,Denial of Service,password flaw,Patch,Samba""/>

<meta name="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="computing_news"/>
<meta name="twitter:domain" content="//www.computing.co.uk/">
<meta property="twitter:creator" content=""/>
<meta property="twitter:url" content="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords"/>
<meta property="twitter:image" content="http://www.computing.co.uk/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-370x229.jpg"/>
<meta property="twitter:description" content="Samba has released security updates for two vulnerabilities in the open-source"/>
<meta itemprop="name" content="Samba patches flaw that let people change admin passwords | Computing"/>
<meta itemprop="description" content="Samba has released security updates for two vulnerabilities in the open-source,Security ,Security,Denial of Service,password flaw,Patch,Samba"/>
<meta itemprop="image" content="http://www.computing.co.uk/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-370x229.jpg"/>





		
		<link href="//assets.computing.co.uk/cdn/ctg/styles/styles.css" media="all" rel="stylesheet" type="text/css">

		<!--[if lt IE 9]>
		<script src="http://assets.computing.co.uk/cdn/global/scripts/html5shiv.js"></script>
		<link href="http://assets.computing.co.uk/respond-proxy.html" id="respond-proxy" rel="respond-proxy" />
		<link href="/images/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" />
		<![endif]-->
		
		<!--[if lt IE 9]>
        	<script src="http://assets.computing.co.uk/cdn/global/scripts/respond.js"></script>
           	<script src="/javascripts/respond.proxy.js"></script>
		<![endif]-->
              <!-- START below code is used for universalvariablestring purpose -->
<!-- END above code is used for universalvariablestring purpose -->

<script type="text/javascript" language="Javascript">
universal_variable_string = '{ "content": { "article":"news", "source":"Computing", "author":"nicholas-fearn", "medium":"text", "published":"2018-03-14T15:03:00+00:00", "tag":["security","denial-of-service","password-flaw","patch","samba"], "image":"/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-185x114.jpg", "restriction":"default","barrier":"free"}, "page": { "url": "https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords", "title": "Samba patches flaw that let people change admin passwords", "description": "Samba has released security updates for two vulnerabilities in the open-source ", "type": "article", "category": "security", "parentcategory": "security", "id": "3028459", "environment": "live", "site":"computing.co.uk", "platform":"desktop"} }';
</script>

		<!-- Start: GIT head script -->
                       <script type="text/javascript" src='//assets.computing.co.uk/javascript/live/computing/javascript-computing.head.min.js'></script>
               <!-- End: GIT head script -->
		 
		<script>
		(function(H){H.className=H.className.replace(/\bno-js\b/,'')})(document.documentElement);
		(function(H){H.className=H.className.replace(/\bno-svg\b/,'')})(document.documentElement);
		 !function(){"use strict";function e(e,t,s){e.addEventListener?e.addEventListener(t,s,!1):e.attachEvent&&e.attachEvent("on"+t,s)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function s(){if(window.localStorage&&window.XMLHttpRequest)if(t(n))c(localStorage.font_css_cache);else{var e=new XMLHttpRequest;e.open("GET",n,!0),e.onreadystatechange=function(){4===e.readyState&&200===e.status&&(c(e.responseText),localStorage.font_css_cache=e.responseText,localStorage.font_css_cache_file=n)},e.send()}else{var s=document.createElement("link");s.href=n,s.rel="stylesheet",s.type="text/css",document.getElementsByTagName("head")[0].appendChild(s),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.setAttribute("type","text/css"),document.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var n="//assets.computing.co.uk/cdn/iw/styles/fonts/sourcesans_sourcesansbold.css?ver=1";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?s():e(window,"load",s)}();
		</script>
        <script src="//code.jquery.com/jquery-1.11.2.min.js"></script>
	</head>
			<body class="article ctg">
	<div id="rdm-overlay" class="ad-slot-overlay"></div>
	<div id="rdm-wallpaper" class="ad-slot-wallpaper"></div>
			<div class="container">
				<aside class="content">
	<div class="content-inner content-full-width">
		<div class="main-content">
				<div id="rdm-above-header" class="ad-slot-full"></div>
		</div>
	</div>
</aside>

				<div class="menu-sidebar">
	<div class="menu-sidebar-inner">
		<div class="search-3 header-search-holder blur">
			<form id="search_form" action="/search" accept-charset="UTF-8" method="get">
				<input type="submit" value="" aria-labelledby="Search" />
				<span>
					 <input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
				</span>
				<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
				<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
				<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form>		</div>
	</div>
	<nav class="mobile-nav">
	<ul class="mobile-nav-ul">
		<li class="active">
		    <div class="mobile-menu-title">
		        <a title="Home" href="/">Home</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="News" href="/type/news">News</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="Big Data &amp; Analytics" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="DevOps" href="/category/devops">DevOps</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="Security" href="/category/security">Security</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="GDPR" href="/tag/gdpr ">GDPR</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="IoT" href="/category/internet-of-things">IoT</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="OpenSource" href="/category/software/open-source">OpenSource</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="Cloud &amp; Infrastructure" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
		    </div>
		</li>
		<li >
		    <div class="mobile-menu-title">
		        <a title="Leadership" href="/category/leadership">Leadership</a>
		    </div>
		</li>
  </ul>
</nav>
<div class="menu-sidebar-inner"> 
    <ul class="sidebar-list">
		        <li>
		        	<a href="/events" target="_blank">Events</a>
		        </li>


			        <li>
			        	<a href="//www.computing.co.uk/static/resources" target="_blank">Resources</a>
			        </li>


	        
		        <li>
		        	<a href="https://www.computing.co.uk/static/spotlights">
					   Spotlights</a>
		        </li> 
		        <li>
		        	<a href="https://www.computing.co.uk/series/profile/top-100-cios">Top 100 CIOs</a>
		        </li>


		        <li>
		        	<a href="//www.computing.co.uk/static/research">Research</a>
		        </li>


        


			<li class="nav-tools newsletters">
				<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
			</li>
        <li class="nav-tools login-icon menu-login-trigger"><a href="">Sign in</a></li>
    </ul>
</div> 

</div>

<nav class="main-top-nav">  
	<ul class="main-top-content main-top-menu content-width">
			<li class="main-top-title main-top-tab-panel main-top-events" id="events">
				<a href="/events" target="_blank">Events</a>
				<ul class="menu-top-panel">
					<li>
						<!-- ::::::::::::::::::::: events panel content start  ::::::::::::::::::::: -->
						<div class="section group content">
							<div class="col-lrg span-lrg_4_of_5 latest-events">
		<header>
			<div class="menu-top-panel-heading">
				Upcoming events
			</div>
		</header>
		<div class="latest-events-holder" id="featured-event">
				<article>
				    <div class="image-text-group-a">
				        <a target="_blank" href="http://events.computing.co.uk/devops"><img alt="event logo" title="DevOps Summit" src="https://www.incisive-events.com/IMG/973/62973/ctgdo17-logo-130x80.jpg" /></a>
				    </div>
				    <div class="image-text-group-b">
				        <h5 class="listings-article-title">
				        	<a href="http://events.computing.co.uk/devops" title="DevOps Summit" target="_blank">DevOps Summit</a>
				        </h5>
							<p class="truncate-listing">
								DevOps has become an inescapable word in technology circles recently with many firms wanting to reap the benefits of bringing developers and operations together. This conference will bring senior IT decision-makers to discuss the latest strategies for DevOps implementation.
							</p>
				        <ul class="article-meta-details">
							<li>
								<time itemprop="datePublished" datetime="21-03-2018">
									<strong>Date:</strong> 21 Mar 2018
								</time>
							</li>
							<li>
								London Marriott Hotel Grosvenor Square
Grosvenor Square
London
W1K 6JP, London
							</li>
						</ul> 
				    </div>
				</article>
				<article>
				    <div class="image-text-group-a">
				        <a target="_blank" href="http://events.computing.co.uk/devopsexcellence"><img alt="event logo" title="DevOps Excellence Awards 2018" src="https://www.incisive-events.com/images/event_default_130x90.png" /></a>
				    </div>
				    <div class="image-text-group-b">
				        <h5 class="listings-article-title">
				        	<a href="http://events.computing.co.uk/devopsexcellence" title="DevOps Excellence Awards 2018" target="_blank">DevOps Excellence Awards 2018</a>
				        </h5>
							<p class="truncate-listing">
								Computing&#39;s DevOps Excellence Awards showcases outstanding achievement from organisations, personalities and solutions operating within the DevOps space.
							</p>
				        <ul class="article-meta-details">
							<li>
								<time itemprop="datePublished" datetime="21-03-2018">
									<strong>Date:</strong> 21 Mar 2018
								</time>
							</li>
							<li>
								London Marriott Hotel Grosvenor Square, London
							</li>
						</ul> 
				    </div>
				</article>
		</div>
		<div class="latest-events-holder">
				<article>
				    <div class="image-text-group-a">
				        <a target="_blank" href="http://events.computing.co.uk/cloud-north"><img alt="event logo" title="Cloud &amp; Infrastructure Summit North" src="https://www.incisive-events.com/IMG/233/59233/ctgcis17-logo680x120-v2-130x80.jpg" /></a>
				    </div>
				    <div class="image-text-group-b">
				        <h5 class="listings-article-title">
				        	<a href="http://events.computing.co.uk/cloud-north" title="Cloud &amp; Infrastructure Summit North" target="_blank">Cloud &amp; Infrastructure Summit North</a>
				        </h5>
							<p class="truncate-listing">
								Cloud computing has already proven to bring multiple benefits to its users - it is flexible, scalable and eliminates the enormous capital costs of designing and building your own infrastructure.  Join us for this one day FREE* event to network with your peers, meet leading industry vendors and learn
							</p>
				        <ul class="article-meta-details">
							<li>
								<time itemprop="datePublished" datetime="18-04-2018">
									<strong>Date:</strong> 18 Apr 2018
								</time>
							</li>
							<li>
								The Lowry Hotel, Manchester
							</li>
						</ul> 
				    </div>
				</article>
				<article>
				    <div class="image-text-group-a">
				        <a target="_blank" href="http://events.computing.co.uk/bigdataexcellence"><img alt="event logo" title="Big Data Excellence Awards 2018" src="https://www.incisive-events.com/IMG/941/62941/ctgbdea18-logo-130x80.jpg" /></a>
				    </div>
				    <div class="image-text-group-b">
				        <h5 class="listings-article-title">
				        	<a href="http://events.computing.co.uk/bigdataexcellence" title="Big Data Excellence Awards 2018" target="_blank">Big Data Excellence Awards 2018</a>
				        </h5>
							<p class="truncate-listing">
								The Big Data &amp; IoT Excellence Awards celebrate the achievements of the IT industry&#39;s best Big Data and IoT companies, solutions, products and personalities.
							</p>
				        <ul class="article-meta-details">
							<li>
								<time itemprop="datePublished" datetime="16-05-2018">
									<strong>Date:</strong> 16 May 2018
								</time>
							</li>
							<li>
								Grand Connaught Rooms, London
							</li>
						</ul> 
				    </div>
				</article>
		</div>
	<div class="panel-section-footer">
		<div class="more-holder">
			<a class="more-link" href="/events" target="_blank">
				<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
					<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
				</svg> 
				View all events
			</a>
		</div>
	</div>
</div>
				
							
						</div>
						<!-- ::::::::::::::::::::: events panel content end  ::::::::::::::::::::: -->
					</li>
				</ul>
			</li>

			<li class="main-top-title main-top-tab-panel main-top-hound" id="hound">
				   <a href="//www.computing.co.uk/static/resources" target="_blank">Resources</a>
				<ul class="menu-top-panel">
					<li>
						<!-- ::::::::::::::::::::: hound panel content start  ::::::::::::::::::::: -->
						<div class="section group content">
							<div class="col span-lrg_4_of_5">
									<header>
										<div class="menu-top-panel-heading">LATEST WHITEPAPERS</div>
									</header>
								<section class="top-panel-paper">
	<div class="image-text-group-a">
		<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3460&amp;sid=$AMF_contact_id$-$AMF_contact_guid$_&amp;campaignname=$AMF_campaign_name$"><img src="/w-images/b73ab161-a14c-4c2f-bcc0-6e3b48cc12f1/1/computingresourcess-120x194.png" alt="Computingresourcess 120x194" /></a>
	</div>
	<div class="image-text-group-b">
		<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3460&amp;sid=$AMF_contact_id$-$AMF_contact_guid$_&amp;campaignname=$AMF_campaign_name$">Economic, operational and strategic benefits of security framework adoption</a>
		<p>Security framework adoption is at an all-time high.&nbsp; Basing your security program on an established framework gives you the controls, KPIs and vocabulary needed for building a structured, scalable, and effective practice.&nbsp; Read more to learn about the business and security benefits that come from adopting a security framework.</p>
		<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3460&amp;sid=$AMF_contact_id$-$AMF_contact_guid$_&amp;campaignname=$AMF_campaign_name$">Download</a>
	</div>
</section>
	                            <section class="top-panel-paper">
	<div class="image-text-group-a">
		<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3430&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/a5c4e52c-9be4-48b2-a688-9fb4eaa0ce1a/1/computingresourcess-120x194.png" alt="Computingresourcess 120x194" /></a>
	</div>
	<div class="image-text-group-b">
		<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3430&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Non-malware attacks and ransomware take centre stage</a>
		<p>This report looks at research from over 1000 organisation, representing more than 2.5 million endpoints, to understand the prevalence and growth of non-malware attacks.</p>
<p>Download now to find out more.</p>
		<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3430&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
	</div>
</section>
							</div>
							
<div class="col span-lrg_1_of_5">
	<section class="hound-search">
		<header>
			<div class="menu-top-panel-heading">Find resources</div>
			<div class="menu-top-panel-subheading">Search by title or subject area</div>
		</header>
		<aside>
			<form target="_blank" name="multi" method="get" id="hound-search" enctype="multipart/form-data" action="//www.computing.co.uk/static/resources-search-results">
				<input type="search" id="search-hound" placeholder="Search papers here" tabindex="1" required="" name="wpSearch">
					<input type="hidden" value="computing" name="publisher">
				<input type="submit" class="btn search-hound">
			</form>		
		</aside>
	</section>
	<div class="panel-section-footer">
		<div class="more-holder">
			<a class="more-link" href="https://www.computing.co.uk/static/resources" target="_blank">
				<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
					<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
				</svg> 
				View all resources
			</a>
		</div>
	</div>
</div>

						</div>
						<!-- ::::::::::::::::::::: hound panel content end  ::::::::::::::::::::::: -->
					</li>
				</ul>
			</li>

			<li class="main-top-title main-top-tab-panel main-top-spotlight" id="spotlight">
				<a href="https://www.computing.co.uk/static/spotlights" target="_blank">
				   Spotlights
				</a>
				<ul class="menu-top-panel">
					<li>
						<div class="section group content">
							<div class="col span-lrg_3_of_3">
								<header>
									<div class="menu-top-panel-heading">Spotlights</div>
								</header>

	                            <section class="top-spotlight">
	<div class="image-text-group-b">
		<strong>
			
		</strong>
		<p>Welcome to Computing's Spotlight section, where we focus in on particularly important themes and topics of enterprise IT.</p>
	</div>
</section>


	                            <section class="top-spotlight">
	<div class="image-text-group-b">
		<strong>
			
		</strong>
		<p><img border="0" alt="" src="/w-images/075273fc-090a-4ad2-9fd4-ab11e6f553b1/1/spotlightibm-200x110.png" caption="false" height="110" width="200" /></p>
<h3><strong><a href="https://www.computing.co.uk/ctg/content-hub/3005362/data-insight">Driven by Data in association with IBM</a></strong></h3>
<p>The channel looks at how software-defined storage is an enabler of multi-cloud, AI, IoT, and arguably plays a pivotal role in digital transformation.</p>
<p><img border="0" alt="" src="/w-images/6ac2180c-a628-4b61-9dbb-d445eabf2cc4/1/spotlightmalware-200x100.png" caption="false" height="110" width="200" /></p>
<h3><a href="https://www.computing.co.uk/ctg/content-hub/3008139/security-spotlight">Security Spotlight in association with Malwarebytes</a></h3>
<p>The channel looks at all things security, including all the news, analyses, opinion and research into these new, yet clear and present, dangers.</p>
	</div>
</section>
	                            
	                        </div>
						</div>
					</li>
				</ul>
			</li>



		        <li class="main-top-title main-top-tab-link main-top-fundcentre" id="">
		            <a href="https://www.computing.co.uk/series/profile/top-100-cios">Top 100 CIOs</a>
		        </li>
				<li class="main-top-title main-top-tab-link main-top-advertise" id="">
				    <a href="//www.computing.co.uk/static/research">Research</a>
				</li>

		<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-login" id="login" style="display:none;">	
	<a href="/userlogin">Sign in</a>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-user" id="user" style="display: none;">
	<a href="/home/manage_account" class="user-info"></a>
	
<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a href="https://www.computing.co.uk/userlogin" title="Sign in">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a href="https://www.computing.co.uk/userlogin" title="Sign in" class="sign-in-user-link">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>
	
<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu"><!-- <li><a href="http://www.computing.co.uk/home/manage_account" title="Saved articles" class="saved-articles-user-link">Saved articles</a></li> -->
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>
<!-- <li><a class="apps-user-link" title="Apps" href="http://www.computing.co.uk/static/apps">Apps</a></li> -->
<li><a class="account-user-link" title="Account details" href="https://www.computing.co.uk/home/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="https://www.computing.co.uk/home/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="https://www.computing.co.uk/home/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>
</li>	
		<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-sociallinks" id="follow" style="display:none;">
			<a href="#">Follow us</a>
			<ul class="header-tools-content">
				<li>
	<div class="nav-tools rss-icon">
		<a href="//www.computing.co.uk/rss-feeds" target="_blank">RSS</a>
	</div>
</li>
<li>
	<div class="nav-tools twitter-icon">
		<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
	</div>
</li>
<li>
	<div class="nav-tools linkedin">
		<a href="https://www.linkedin.com/groups?gid=2366689" target="_blank">LinkedIn</a>
	</div>
</li>
<li>
	<div class="nav-tools newsletters">
		<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
	</div>
</li>

			</ul>
		</li>
			<li class="main-top-title main-top-align-right main-top-tab-link main-top-register" id="register" style="display:none;">
		<a href="//www.computing.co.uk/static/register" target="_blank">Register</a>
	</li>
<li class="main-top-title main-top-align-right main-top-user-status" id="rdm_header_user_status_link"></li>

 


        


	</ul>
</nav>


<header role="banner" class="main-head">

<div class="main-head-content content-width">
    <div class="site-header">
    	    <div class="site-logo-holder" itemscope itemtype="http://schema.org/Organization">
	<div itemprop="name" class="screen-reader-text">
		Computing
	</div>
	<a href="/" title="Return to homepage" class="site-logo"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="Computing" class="sprite investmentweek-logo"></a>
</div>
			<div class="search-1 header-search-holder blur">



				<form id="search_form_bottom" action="/search" accept-charset="UTF-8" method="get">
					<input type="submit" value="" aria-labelledby="Search" />
					<span>
						 <input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
					</span>
					<input type="hidden" name="per_page" id="per_page" value="24" class="hidden_style" />
					<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
					<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form>			</div>
			<!-- search-1 header-search-holder blur end -->
		</div>
	</div>
</header>

<nav class="nav">
	<div class="holder">
		<div class="hamburger-style" id="nav-toggle" aria-label="Menu">
			<span></span>
		</div>
		<div class="clicker4" aria-label="Login"></div>
		<script type="text/conditional-html" id="tablet-conditional-navigation">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</script>
		<div id="conditional-navigation" class="" >
			<!-- no script default fall back -->
			<nav class="primary-nav nav-colour01" role="navigation" aria-label="Primary">
				<ul class="main-menu main-top-content content-width">
						<li class="menu-title">
							<a title="Home" href="/">Home</a>
						</li>
						<li class="menu-title">
							<a title="News" href="/type/news">News</a>
						</li>
						<li class="menu-title">
							<a title="Big Data &amp; Analytics" href="/category/big-data-and-analytics">Big Data &amp; Analytics</a>
						</li>
						<li class="menu-title">
							<a title="DevOps" href="/category/devops">DevOps</a>
						</li>
						<li class="menu-title">
							<a title="Security" href="/category/security">Security</a>
						</li>
						<li class="menu-title">
							<a title="GDPR" href="/tag/gdpr ">GDPR</a>
						</li>
						<li class="menu-title">
							<a title="IoT" href="/category/internet-of-things">IoT</a>
						</li>
						<li class="menu-title">
							<a title="OpenSource" href="/category/software/open-source">OpenSource</a>
						</li>
						<li class="menu-title">
							<a title="Cloud &amp; Infrastructure" href="/category/cloud-and-infrastructure">Cloud &amp; Infrastructure</a>
						</li>
						<li class="menu-title">
							<a title="Leadership" href="/category/leadership">Leadership</a>
						</li>
				</ul>
			</nav>
		</div>
		<div class="mobile-branding"><a href="/" class="mobile-branding-link" alt="Computing" ></a></div> 
	</div>
	<div class="mask">
	<div class="menu4">
		<div>
			<a href="/home/manage_account" class="user-info"></a>
			
<div id="rdm-above-corp-menu">&nbsp;</div>
<ul class="header-tools-content institutional" style="display: none;">
<li>
<div class="corporate-menu-information">
<p class="corporate-menu-information-introduction">You are currently accessing Computing via your Enterprise account.</p>
<p>If you already have an account please use the link below to <a href="https://www.computing.co.uk/userlogin" title="Sign in">sign in</a>.</p>
<p>If you have any problems with your access or would like to request an individual access account please contact our customer service team.</p>
<p>Phone: <a href="tel:+441858438800">+44 (0) 1858 438800</a></p>
<p>Email: <a href="mailto:customerservices@incisivemedia.com">customerservices@incisivemedia.com</a></p>
</div>
<ul class="user-menu">
<li><a href="https://www.computing.co.uk/userlogin" title="Sign in" class="sign-in-user-link">Sign in</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-corp-menu">&nbsp;</div>

<div id="rdm-above-user-menu">&nbsp;</div>
<ul class="header-tools-content individual" style="display: none;">
<li>
<ul class="user-menu"><!-- <li><a href="http://www.computing.co.uk/home/manage_account" title="Saved articles" class="saved-articles-user-link">Saved articles</a></li> -->
<li><a class="newsletters-user-link" title="Newsletters" href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form">Newsletters</a></li>
<!-- <li><a class="apps-user-link" title="Apps" href="http://www.computing.co.uk/static/apps">Apps</a></li> -->
<li><a class="account-user-link" title="Account details" href="https://www.computing.co.uk/home/manage_account#myaccount">Account details</a></li>
<li><a class="contact-user-link" title="Contact support" href="https://www.computing.co.uk/home/manage_account#contact">Contact support</a></li>
<li><a class="sign-out-user-link" title="Sign out" href="https://www.computing.co.uk/home/logout">Sign out</a></li>
</ul>
</li>
</ul>
<div id="rdm-below-user-menu">&nbsp;</div>
		</div>
	</div>
</div>
</nav>

<aside class="content">
	<div class="content-inner content-full-width">
		<div class="main-content">
				<div id="rdm-below-header" class="ad-slot-full"></div>
		</div>
	</div>
</aside>


				<div class="page-content ajax_search">
							<header class="article-header">
	<div class="content">
		<div class="content-inner">
			<div class="main-content">
				<div class="section group">
					<div class="col span_1_of_5">
						
						<img class="print-branding" src="//assets.computing.co.uk/cdn/ctg/images/site-logo.png" alt="Computing">
						

						

						<nav>
							<ul class="meta-taxonomy-list breadcrumb">
									<li>
										<a href="/category/security/">Security</a>
									</li>
							</ul>
						</nav>
					</div>
					<div class="col span_4_of_5">
						<h1 itemprop="name" class="article-title">Samba patches flaw that let people change admin passwords</h1>
							<h2 class="article-sub-title">Samba has released security updates for two vulnerabilities in the open-source </h2>
					</div>
				</div>
			</div><!--  end main-content -->
		</div><!-- content-inner end  -->
	</div><!-- content end -->
</header>
	<div class="content">
		<main role="main" class="content-inner">
			<div class="main-content">
					<article class="section group article"> 
		<div class="col span_1_of_5"></div>
		<div class="col span_4_of_5 article-col">
								<figure class="main">
						<img alt="Samba patches flaw that let people change admin passwords" title="Samba patches flaw that let people change admin passwords" src="/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-580x358.jpg" />
						
					</figure>

			<div class="article-meta-container group">
				


	<ul class="meta-taxonomy-list author-dateline ">
				<li class="author-dateline-image">
					<a title="Nicholas Fearn" href="/author/profile/6036/nicholas-fearn"><img class="author-pic" alt="Nicholas Fearn" src="/w-images/f63bc5a6-5ba3-4878-bd68-82aa78734744/0/NicFearn-100x100.jpg" /></a>
				</li>
			<li class="author-dateline-name">
				<a href="/author/profile/6036/nicholas-fearn">Nicholas Fearn</a>
			</li>
			<li class="author-dateline-time">
				<time datetime="2018-03-14" itemprop="datePublished">
					14 March 2018
				</time>
			</li>
	</ul>

				<div class="tools-meta-outer">
	<ul class="tools-container">
		<li>

			<div title="Tweet" class="article-tools twitter-icon icons pos1">
			<span title="Tweet" class="screen-reader-text">Tweet</span>
			<a href="https://twitter.com/share?text=Samba+patches+flaw+that+let+people+change+admin+passwords&amp;url=https://www.computing.co.uk/3028459/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
		</div>
		</li>
		<li>
			<div title="Facebook" class="article-tools facebook-icon icons pos2">
				<span class="screen-reader-text">Facebook</span>
				<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/3028459" rel="nofollow" target="_blank">&nbsp;</a>
			</div>
		</li>




		<li>
			<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
				<span class="screen-reader-text">LinkedIn</span>
				<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/3028459&amp;title=Samba+patches+flaw+that+let+people+change+admin+passwords" rel="nofollow" target="_blank">&nbsp;</a>
			</div>
		</li>

			<li>
				<div title="Google plus" class="article-tools gplus-icon icons pos4">
					<span class="screen-reader-text">Google plus</span>
					<a href="https://plus.google.com/share?url=https://www.computing.co.uk/3028459" rel="nofollow" target="_blank">&nbsp;</a>
				</div>
			</li>
		<!-- <li>
			<div title="Save article" class="article-sticky-tools save-icon icons pos5">
				<span class="screen-reader-text">Save this article</span>
				<a onclick="savedArticleStatus(); return false;" href="#">&nbsp;</a>
			</div>
		</li> -->
		<li>
			<div title="Send to" class="article-tools email-icon icons pos6">
				<span class="screen-reader-text">Send to</span>
				<a target="_blank" rel="nofollow" href="mailto:?subject=Samba patches flaw that let people change admin passwords&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F3028459">&nbsp;</a>
			</div>
		</li>
	</ul>
	<!-- tools end -->
	<div class="article-meta-numbers">      
	    <div class="comment-count">
	    	<a href="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords#disqus_thread">0 Comments</a>
	    </div>
	    <div class="social-count">
	        <a href="https://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords"><span class="share-total"></span></a>
	    </div>
	</div>
</div><!-- tools-meta-outer end -->
			</div>
			
		<div id="rdm-below-summary"></div>
			<div class="article-page-body-content">
				<!-- <div class="article-content"> -->
					   

	
	
	<p dir="ltr">Samba has released patches to fix two serious security vulnerabilities in its widely used open-source Windows and Linux&nbsp;networking software.</p>
<p>The patches were rushed out after security specialists found password and denial-of-service flaws, which can be found in all versions of the software released since December 2012.</p>
	
	<div id="rdm-above-related"></div>
	
	
<p dir="ltr">By tapping into the password vulnerability, anyone with access to a Samba 4.x LDAP server can modify other people's login details. They just have to create an Active Directory Domain Controller.</p>
	
	
	
<p dir="ltr">People logged into the software can also change admin and service account passwords, but Samba explained that it has now fixed this bug for versions 4.7.6, 4.6.14 and 4.5.16.</p>
<p dir="ltr">Alongside the patch, the organisation has released workaround options that can help administrators determine whether someone has meddled with passwords.</p>
<p dir="ltr">"Revoke the change passwords right for 'the world' from all user objects (including computers) in the directory, leaving only the right to change a user's own password," it recommends.</p>
<p dir="ltr">It advised users to upgrade or apply the patch as soon as possible.</p>
<p>"As Samba does not at this time change the machine account passwords of Domain Controllers, any change to these, or to the passwords of administrators should be a concern."</p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">Quick exposure reminder: There are still plenty of internet-facing Samba instances around. Results from last week's Project Sonar study below (correlation with today's Samba CVE not implied). H/t Rapid7's <a href="https://twitter.com/hrbrmstr?ref_src=twsrc%5Etfw">@hrbrmstr</a> and <a href="https://twitter.com/TomSellers?ref_src=twsrc%5Etfw">@TomSellers</a>. <a href="https://t.co/m661VJaAnx">pic.twitter.com/m661VJaAnx</a></p>
&mdash; Rapid7 (@rapid7) <a href="https://twitter.com/rapid7/status/973559963430871040?ref_src=twsrc%5Etfw">March 13, 2018</a></blockquote>
<script charset="utf-8" src="https://platform.twitter.com/widgets.js" async=""></script>
<p>There is a patch for a new denial-of-service flaw, too. But that flaw should only affect a few&nbsp;particular configurations.</p>
<p>The DDoS flaw was found in Samba 4.7.6, 4.6.14 and 4.5.16, although users of Samba 4.4.16 and 4.3.13 can download the patch as well.</p>
<p dir="ltr">"All versions of Samba from 4.0.0 onwards are vulnerable to a denial-of-service attack when the RPC spoolss service is configured to be run as an external daemon," <a title="Samba.org" href="https://www.samba.org/samba/security/CVE-2018-1050.html" target="_blank" rel="noopener noreferrer">explained CVE-2018-1050</a>.</p>
<p dir="ltr">"Missing input sanitization checks on some of the input parameters to spoolss RPC calls could cause the print spooler service to crash," it added.</p>
<p dir="ltr">Writing on Twitter, cyber security firm Rapid7 suggested that these flaws may only be scratching above the surface. "There are still plenty of internet-facing Samba instances around," it warned, suggesting that they need to be updated, and fast.</p>
		<div id="rdm-below-article-text"></div>

				<!-- </div> -->
				



				
				<!-- <footer> -->
				<div id="rdm-below-article-body"></div>
<ul class="tools-container">
	<li>

			<div title="Tweet" class="article-tools twitter-icon icons pos1">
			<span title="Tweet" class="screen-reader-text">Tweet</span>
			<a href="https://twitter.com/share?text=Samba+patches+flaw+that+let+people+change+admin+passwords&amp;url=https://www.computing.co.uk/3028459/&via=computing_news" rel="nofollow" target="_blank">&nbsp;</a>
		</div>
	
	</li>
	<li>
		<div title="Facebook" class="article-tools facebook-icon icons pos2">
			<span class="screen-reader-text">Facebook</span>
			<a href="https://www.facebook.com/sharer.php?u=https://www.computing.co.uk/3028459" rel="nofollow" target="_blank">&nbsp;</a>
		</div>
	</li>




	<li>
		<div title="LinkedIn" class="article-tools linkedin-icon icons pos3">
			<span class="screen-reader-text">LinkedIn</span>
			<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.computing.co.uk/3028459&amp;title=Samba+patches+flaw+that+let+people+change+admin+passwords" rel="nofollow" target="_blank">&nbsp;</a>
		</div>
	</li>

	<li>
		<div title="Google plus" class="article-tools gplus-icon icons pos4">
			<span class="screen-reader-text">Google plus</span>
			<a href="https://plus.google.com/share?url=https://www.computing.co.uk/3028459" rel="nofollow" target="_blank">&nbsp;</a>
		</div>
	</li>
	
	
	<!-- <li>
		<div title="Save article" class="article-sticky-tools save-icon icons pos5">
			<span class="screen-reader-text">Save this article</span>
			<a onclick="savedArticleStatus(); return false;" href="#">&nbsp;</a>
		</div>
	</li> -->
	
	
	<li>
		<div title="Send to" class="article-tools email-icon icons pos6">
			<span class="screen-reader-text">Send to</span>
			<a target="_blank" rel="nofollow" href="mailto:?subject=Samba patches flaw that let people change admin passwords&amp;body=%0D%0A%0D%0Ahttp%3A%2F%2Fwww.computing.co.uk%2F3028459">&nbsp;</a>
		</div>
	</li>
	
</ul>
				<!-- tools end -->
				<ul class="meta-taxonomy-list related-links">
	<li>
		Topics
	</li>
	<li>
		<a href="/category/security/">Security</a>
	</li>
	<li>
		<a href="/tag/security/">Security</a>
	</li>
	<li>
		<a href="/tag/denial-of-service/">Denial of Service</a>
	</li>
	<li>
		<a href="/tag/password-flaw/">password flaw</a>
	</li>
	<li>
		<a href="/tag/patch/">Patch</a>
	</li>
	<li>
		<a href="/tag/samba/">Samba</a>
	</li>
</ul>

				<!-- about author start -->
				
				<!-- about author end -->
			</div>
		</div>
	</article>
	<!-- article chunk end  -->
	<div id="rdm-above-series-blog"></div>
	<div id="rdm-above-related"></div>
	<!-- end related articles  -->
	<div id="rdm-above-more-news"></div>
	<section class="news-articles">
	<header class="related-listings-header">
		<h4 itemprop="name">More news</h4>
	</header>
	<div class="section group">
		<article class="col span_2_of_4 first-element">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028464/gwent-police-facing-investigation-over-data-breach-cover-up"><img title="Gwent Police facing investigation over data breach cover-up" alt="Gwent Police facing investigation over data breach cover-up" src="/w-images/eaa4712c-a90d-4f21-9fe0-ff5a4d76b627/1/breachblackglove-230x142.jpg" /></a>



 
			</div>
			<div class="image-text-group-b">
				     <h5 class="listings-article-title"><a title="Gwent Police facing investigation over data breach cover-up" href="/ctg/news/3028464/gwent-police-facing-investigation-over-data-breach-cover-up">Gwent Police facing investigation over data breach cover-up</a></h5>

				<p class="section-story">
					Confidential information about reports filed online could have been compromised

				</p>
				<ul class="article-meta-details" >
	<li>
		<a class="ctg-link" href="/category/security/">Security</a>
	</li>
	<li>
		<time datetime="2018-03-14" itemprop="datePublished">
			14 March 2018
		</time>
	</li>
</ul>
			</div>
		</article>
		<article class="col span_2_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords"><img title="Samba patches flaw that let people change admin passwords" alt="Samba patches flaw that let people change admin passwords" src="/w-images/57a76dd0-f059-48fd-ad17-b776a68c8775/1/networkcablesoriginal-230x142.jpg" /></a>



 
			</div>
			<div class="image-text-group-b">
				     <h5 class="listings-article-title"><a title="Samba patches flaw that let people change admin passwords" href="/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords">Samba patches flaw that let people change admin passwords</a></h5>

				<p class="section-story">
					Samba has released security updates for two vulnerabilities in the open-source

				</p>
				<ul class="article-meta-details" >
	<li>
		<a class="ctg-link" href="/category/security/">Security</a>
	</li>
	<li>
		<time datetime="2018-03-14" itemprop="datePublished">
			14 March 2018
		</time>
	</li>
</ul>
			</div>
		</article>
		<article class="col span_2_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028458/france-to-sue-google-and-apple-over-abuse-business-practices-that-exploit-developers"><img title="Paris" alt="Paris" src="/w-images/4b93db18-b667-462f-a44e-d6a8569c4090/2/parisarcdetriomphefrance-230x142.jpg" /></a>



 
			</div>
			<div class="image-text-group-b">
				     <h5 class="listings-article-title"><a title="France to sue Google and Apple over &#39;abuse business practices&#39; that exploit developers" href="/ctg/news/3028458/france-to-sue-google-and-apple-over-abuse-business-practices-that-exploit-developers">France to sue Google and Apple over &#39;abuse business practices&#39; that exploit developers</a></h5>

				<p class="section-story">
					France takes aim, once again, at US technology giants

				</p>
				<ul class="article-meta-details" >
	<li>
		<a class="ctg-link" href="/category/software/">Software</a>
	</li>
	<li>
		<time datetime="2018-03-14" itemprop="datePublished">
			14 March 2018
		</time>
	</li>
</ul>
			</div>
		</article>
		<article class="col span_2_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028454/obituary-professor-stephen-hawking-1942-2018"><img title="Obituary - Professor Stephen Hawking, 1942-2018" alt="Obituary - Professor Stephen Hawking, 1942-2018" src="/w-images/22993e4c-5b42-4aa1-ae75-95da254116c3/0/stephenhawking6-230x142.png" /></a>



 
			</div>
			<div class="image-text-group-b">
				     <h5 class="listings-article-title"><a title="Obituary - Professor Stephen Hawking, 1942-2018" href="/ctg/news/3028454/obituary-professor-stephen-hawking-1942-2018">Obituary - Professor Stephen Hawking, 1942-2018</a></h5>

				<p class="section-story">
					One of history&#39;s greatest minds has left this plain

				</p>
				<ul class="article-meta-details" >
	<li>
		<a class="ctg-link" href="/category/big-data-and-analytics/">Big Data and Analytics</a>
	</li>
	<li>
		<time datetime="2018-03-14" itemprop="datePublished">
			14 March 2018
		</time>
	</li>
</ul>
			</div>
		</article>
	</div>
</section>
<!-- end more news -->

	<!-- end more news articles  -->
	<div id="rdm-above-comments"></div>
			<div id="disqus_thread"></div>
<script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.computing.co.uk/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//computing-live.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>

	<div class="scrollup">
		Back to Top
	</div>

			</div><!--  end main-content -->
			<div role="complementary" class="sidebar">
				<div id="rdm-rhc-top" class="ad-slot"></div>
			    <!-- popular-articles - start -->
<section class="popular-articles">
	<header class="related-listings-header">
		<h4 itemprop="name">Most read</h4>
	</header>
	<div class="section group">
		<article class="col span_1_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028458/france-to-sue-google-and-apple-over-abuse-business-practices-that-exploit-developers"><img title="Paris" alt="Paris" src="/w-images/4b93db18-b667-462f-a44e-d6a8569c4090/2/parisarcdetriomphefrance-140x87.jpg" /></a>



 
			</div>
			<div class="image-text-group-b">
				<h5>     <a title="France to sue Google and Apple over &#39;abuse business practices&#39; that exploit developers" href="/ctg/news/3028458/france-to-sue-google-and-apple-over-abuse-business-practices-that-exploit-developers">France to sue Google and Apple over &#39;abuse business practices&#39; that exploit developers</a>
</h5>
			</div>
		</article>
		<article class="col span_1_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028454/obituary-professor-stephen-hawking-1942-2018"><img title="Obituary - Professor Stephen Hawking, 1942-2018" alt="Obituary - Professor Stephen Hawking, 1942-2018" src="/w-images/22993e4c-5b42-4aa1-ae75-95da254116c3/0/stephenhawking6-140x87.png" /></a>



 
			</div>
			<div class="image-text-group-b">
				<h5>     <a title="Obituary - Professor Stephen Hawking, 1942-2018" href="/ctg/news/3028454/obituary-professor-stephen-hawking-1942-2018">Obituary - Professor Stephen Hawking, 1942-2018</a>
</h5>
			</div>
		</article>
		<article class="col span_1_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028436/surveilance-camera-commissioner-warns-government-of-the-need-for-data-protection-to-avoid-nightmare-scenario"><img title="Surveilance camera commissioner warns government of the need for data protection to avoid &quot;nightmare scenario&quot;" alt="Surveilance camera commissioner warns government of the need for data protection to avoid &quot;nightmare scenario&quot;" src="/w-images/e896c623-42fe-415d-915e-661dfcec6a70/1/surveillanceeye-140x87.jpeg" /></a>



 
			</div>
			<div class="image-text-group-b">
				<h5>     <a title="Surveilance camera commissioner warns government of the need for data protection to avoid &quot;nightmare scenario&quot;" href="/ctg/news/3028436/surveilance-camera-commissioner-warns-government-of-the-need-for-data-protection-to-avoid-nightmare-scenario">Surveilance camera commissioner warns government of the need for data protection to avoid &quot;nightmare scenario&quot;</a>
</h5>
			</div>
		</article>
		<article class="col span_1_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028443/broadcom-formally-abandon-plan-to-buy-qualcomm-following-president-trumps-intervention"><img title="Broadcom formally abandon plan to buy Qualcomm following President Trump&#39;s intervention " alt="Broadcom formally abandon plan to buy Qualcomm following President Trump&#39;s intervention " src="/w-images/db01318e-4386-43dc-9b43-48733b420324/1/broadcomlogo-140x87.jpeg" /></a>



 
			</div>
			<div class="image-text-group-b">
				<h5>     <a title="Broadcom formally abandon plan to buy Qualcomm following President Trump&#39;s intervention " href="/ctg/news/3028443/broadcom-formally-abandon-plan-to-buy-qualcomm-following-president-trumps-intervention">Broadcom formally abandon plan to buy Qualcomm following President Trump&#39;s intervention </a>
</h5>
			</div>
		</article>
		<article class="col span_1_of_4">
			<div class="image-text-group-a">
				
<a href="/ctg/news/3028433/amd-ryzen-and-epyc-cpus-contain-13-serious-vulnerabilities-claims-security-start-up"><img title="AMD Ryzen and Epyc CPUs contain 13 serious vulnerabilities, claims security start-up" alt="AMD Ryzen and Epyc CPUs contain 13 serious vulnerabilities, claims security start-up" src="/w-images/30d4746f-9727-476b-b98a-2385ae83b8fc/3/MunchTheScream-140x87.png" /></a>



 
			</div>
			<div class="image-text-group-b">
				<h5>     <a title="AMD Ryzen and Epyc CPUs contain 13 serious vulnerabilities, claims security start-up" href="/ctg/news/3028433/amd-ryzen-and-epyc-cpus-contain-13-serious-vulnerabilities-claims-security-start-up">AMD Ryzen and Epyc CPUs contain 13 serious vulnerabilities, claims security start-up</a>
</h5>
			</div>
		</article>
	</div><!-- end first section group -->
</section>
<!-- popular-articles - end -->


			    <div id="rdm-rhc-whitepapers" class="ad-slot"></div>
			    <div id="rdm-rhc-bottom" class="ad-slot"></div>
			</div>
		</main>
	</div>

				</div>
				<aside class="content">
	<div class="content-inner content-full-width">
		<div class="main-content">
				<div id="rdm-above-footer" class="ad-slot-full"></div>
		</div>
	</div>
</aside>
				<footer class="main-footer">
	<div class="main-footer-content main-footer-links">
		<div class="main-footer-content-inner content-width">
			
<ul class="main-footer-nav">
<li class="menu-title"><a title="" href="//www.computing.co.uk/static/contacts">Contact</a></li>
<li class="menu-title"><a href="http://btgmarketingsolutions.incisivemedia.com/">Marketing solutions</a></li>
<li class="menu-title"><a href="http://www.enterpriseitevents.com/">Enterprise IT Events</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/our-story/" target="_blank" rel="noopener noreferrer">About Incisive Media</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/terms-conditions/" target="_blank" rel="noopener noreferrer">Terms &amp; conditions</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/privacy-policy/" target="_blank" rel="noopener noreferrer">Privacy policy</a></li>
</ul>
			<ul class="footer-tools-content main-footer-align-right">
				<li>
	<div class="nav-tools rss-icon">
		<a href="//www.computing.co.uk/rss-feeds" target="_blank">RSS</a>
	</div>
</li>
<li>
	<div class="nav-tools twitter-icon">
		<a href="https://twitter.com/computing_news" target="_blank">Twitter</a>
	</div>
</li>
<li>
	<div class="nav-tools linkedin">
		<a href="https://www.linkedin.com/groups?gid=2366689" target="_blank">LinkedIn</a>
	</div>
</li>
<li>
	<div class="nav-tools newsletters">
		<a href="http://email.computing.co.uk/k/Incisive-Business/computing_sign_up_form" target="_blank">Newsletters</a>
	</div>
</li>

			</ul>

		</div>
	</div>
	<div class="main-footer-content main-footer-copyright">
		<div class="main-footer-content-inner content-width">
			<div class="incisivemedia-footer">
				
<p class="corp-logo" style="float: left; padding: 20px 10px 0px 5px;"><a title="Incisive Media" href="https://www.incisivemedia.com/" target="_blank" rel="noopener noreferrer"><img src="https://assets.incisivemedia.com/production/global/images/im_logo.png" width="150" height="38" /></a></p>
<p class="copyright-full">&copy; Incisive Business Media (IP) Limited, Published by Incisive Business Media Limited, New London House, 172 Drury Lane, London WC2B 5QR, registered in England and Wales with company registration numbers 09177174 &amp; 09178013</p>
			</div>
			<div class="incisivemedia-accreditation">
				
<div class="accredit-text"><a href="http://www.incisivemedia.com/accreditations" target="_blank" rel="noopener noreferrer">Digital publisher of the year</a></div>
<div class="accreditation-logos"><span class="screen-reader-text">Digital publisher of the year 2010, 2013, 2016 &amp; 2017</span></div>
			</div>

		</div>
	</div>
</footer>
			</div>
	    <script src="/javascripts/cookie.js"></script>
		<script type="text/javascript">
		  jQuery(document).ready(function() {
		    if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
			var userlogin_path=location.pathname;
			if(userlogin_path == "/userlogin"){
			$("span#login_error_message_header").html(getCookie("series_token_error_message").replace(/\+/g, " ")).show();
			deleteCookie("series_token_error_message");
			}}});
			 jQuery(document).ready(function() {
			$("#userlogin .btn.login").on("click",function(){
			$("span#login_error_message_header").html("").hide();
			})});
		</script>
		
		<script type="text/javascript">
		  jQuery(document).ready(function() {
		      if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
		      if(getCookie("series_token_error_message").match("articles$") !=null){
		   $("span#login_error_message_teaser").html(getCookie("series_token_error_message").replace(/\+/g, " ").replace(/\w+$/,'')).show();
		   deleteCookie("series_token_error_message");
		   }
		   }
		   });
		    jQuery(document).ready(function() {
		   $("#login_barrier .login_submit").on("click",function(){
		   $("span#login_error_message_teaser").html("").hide();
		   });});
		</script>

         <script src="//assets.computing.co.uk/cdn/ctg/scripts/scripts.js"></script>
                  
      <script src="/javascripts/KRESearch.js"></script>      
		<script type="text/javascript">
		    jQuery(document).ready(function() {
		    	$("#login").hover(function(){
			       $(".login-offset").hide();
				});
		    	 setTimeout(function(){ 
		    	 	jQuery("#register,#login,#follow,#free-trial").show();
					if(getCookie("logged_in") == "false"){
							jQuery("#register,#login,#follow,#free-trial").show();
						    jQuery("#user").hide();
					}else if(getCookie("logged_in") == "true"  || getCookie("logged_in") == "expired"|| getCookie("logged_in") == null){
							if(getCookie("first_name")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
								$("#user,#follow").show();
						        $("#register,#login,#free-trial").hide();
						        jQuery(".user-info").html('My account');
								if(getCookie("institutional_login") == "true"){
									if(getCookie("individual_login") == "true"){
										$(".individual").show();
										$('.institutional').hide();
										$(".user-info").html('My account');
										$("#user").removeClass("main-top-institution");
									}else{
										$(".individual").hide();
										$(".user-info").html('Welcome');
										$("#user").addClass("main-top-institution");
									}
								}else{
										$(".individual").show();
										$("#user").removeClass("main-top-institution");
								}
							}else{
									jQuery.ajax({
			                        type : 'GET',
			                        dataType : 'html',
			                        beforeSend : function(xhr) {
			                            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'))
			                        },
			                        url : '/user_info',
			                        success : function(data) {
			                            if(getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" ){
			                                if(getCookie("first_name")!= null && getCookie("subc")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
												$("#user,#follow").show();
						        				$("#register,#login,#free-trial").hide();
						        				jQuery(".user-info").html('My account');
												if(getCookie("institutional_login") == "true"){
													if(getCookie("individual_login") == "true"){
														$(".individual").show();
														$('.institutional').hide();
														$(".user-info").html('My account');
														$("#user").removeClass("main-top-institution");
													}else{
														$(".individual").hide();
														$('.institutional').show();
														$(".user-info").html('Welcome');
														$("#user").addClass("main-top-institution");
													}
												}else{
														$(".individual").show();
														$("#user").removeClass("main-top-institution");
												}
			                                }
			                            }
			                           else{
										   $("#register,#login,#follow,#free-trial").show();
									if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
										   var userlogin_path=location.pathname;
										   if(userlogin_path != "/userlogin" &&  (getCookie("series_token_error_message").match("articles$") == null)){
										   location.pathname="/userlogin";
										   }}
										}
			                        }
			                    });
							}
					}
						}, 2000);
				$("#user").hover(function(event){
				   event.preventDefault();
				   if(getCookie("institutional_login") == "true"){
						if(getCookie("individual_login") == "true"){
							$(".individual").show();
							$('.institutional').hide();
						}else{
							$(".individual").hide();
							$('.institutional').show();
						}
					}
				});
			});
		</script>

		<script type="text/javascript">
		/* article teaser csrf token */
		$(function(){
			 jQuery.ajax({
            url : '/article_teaser_login',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                $( "#export_loaders" ).show();              
            },
            success : function(data) {
            	$( "#export_loaders" ).hide();
                $(".art_teaser").html(data);
            }
        });
		});
		</script> 
		
		 <script type="text/javascript">
/*script for login */

    jQuery(document).on('click', '.login_form_submit.login_submit', function(event) {
    	event.preventDefault();
        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery("#userloginpop").serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                 $("#follow,#register,#login,#free-trial").hide();
                  $( "#export_loaders" ).show();
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                	$("#follow,#user").show();
                    location.reload();
                } else {
                	jQuery("#register,#login,#follow,#free-trial").show();
                	$( "#export_loaders" ).hide();
                    jQuery('#login_error_message_header,#login_error_message_teaser').show();
                    jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });

    });
    jQuery(document).on('click', '.btn.login', function(event) {
    	event.preventDefault();
        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery("#userlogin").serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                  $( "#export_loaders" ).show();
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                	var a=$(".cls_redirect").attr("value");
                	location.href=a;
                } else {
                	jQuery("#register,#login,#follow,#free-trial").show();
                	$( "#export_loaders" ).hide();
                    jQuery('#login_error_message_header,#login_error_message_teaser').show();
                    jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });

    });
    jQuery(document).on('click', '.submit_style.login_submit', function(event) {
        event.preventDefault();

        jQuery.ajax({
            url : '/wps/authentication/verify_subscription_login',
            type : 'POST',
            data : jQuery('#login_barrier').serialize(),
            dataType : 'json',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                 setTimeout(function(){ 
                  $( "#export_loaders" ).show();
                 }, 1000);
            },
            success : function(data) {
                if (data.status == "true") {
                	$( "#export_loaders" ).hide();
                    location.reload()
                } else {
                   jQuery("#register,#login,#follow,#free-trial").show();
                   $( "#export_loaders" ).hide();
                   jQuery('#login_error_message_header,#login_error_message_teaser').show();
                   jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
                }
            }
        });
    });
    </script>
	<script type="text/javascript">
		    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
		    var disqus_shortname = 'computing-live'; // required: replace example with your forum shortname
		 var disqus_identifier = "/ctg/news/3028459/samba-patches-flaw-that-let-people-change-admin-passwords";
		    /* * * DON'T EDIT BELOW THIS LINE * * */
		    (function () {
		        var s = document.createElement('script'); 
		        s.async = true;
		        s.type = 'text/javascript';
		        s.src = '//computing-live.disqus.com/count.js';
		        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		    }());
	</script>
	<!-- Start: GIT body script -->
				   <script type="text/javascript" src='//assets.computing.co.uk/javascript/live/computing/javascript-computing.body.min.js'></script>
		<!-- End: GIT body script -->
         <script id="dsq-count-scr" src="//computing-live.disqus.com/count.js" async>
         </script> <!--Replace SITE_SHORTNAME with your site’s shortname-->
	</body>
</html>